forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tamara Harpster" <tharps...@excite.com>
Subject RE: Path for images in PDFs
Date Mon, 04 Oct 2004 16:24:07 GMT

I ran into the same  problem recently and I fixed it by creating a resources/images directory
at the same level as the content directory. This directory gets copied into the webapp directory.
The problem I found later is that this directory doesn't seem to get updated with future forrest
commands.

You might try checking in the developer.log in webapp/WEB-INF/logs directory, I think that's
where I found the error of where forrest was looking for the pdf images and that it was looking
for them in resources/images.


Tamara Harpster


 --- On Mon 10/04, Claus Bech Rasmussen - TELMORE < cbr@telmore.dk > wrote:
From: Claus Bech Rasmussen - TELMORE [mailto: cbr@telmore.dk]
To: user@forrest.apache.org
Date: Mon, 4 Oct 2004 17:25:11 +0200
Subject: Path for images in PDFs

Hi folks,<br><br>I'm running Forrest via Jetty and maybe I just don't understand
how<br>requests are mapped, but here's my scenario:<br><br>I have something
like this in a document:<br><br>    <p><img alt="forrestGif" src="images/111-forrest.gif"
/></p><br><br>The HTML works like a charm, but the images is not included
in the PDF<br>version.<br><br>Now, if I just do this instead:<br><br>
   <p><img alt="forrestGif" src="./images/111-forrest.gif" /></p><br><br>Everything
works fine. <br><br>The document is sitting in a directory under xdocs and so
is the<br>"images" dir. I tried changing the properties so that the images dir was<br>this
local one - that fixed the PDF but broke the HTML.<br><br>Any hints?<br><br>

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!

Mime
View raw message