forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clay Leeds <cle...@medata.com>
Subject forrest wholesite 'bug'
Date Fri, 15 Oct 2004 21:27:33 GMT
There's a minor bug in the whole_site mechanism: It displays the PDFs 
item (which contains only the Whole Site HTML & PDF links) in the 
generated output. This is silly, since it's a circular reference 
(although in the wholesite.html & wholesite.pdf files they have no 
content). These items should have the functionality of PDF-TAB's 
wholesite='false'. Unfortunately, I can't seem to add this. IMO, it 
should actually have this by default.

On a side note, I don't recall this issue[1] ever being resolved. 
However, it appears to be working... FWIW, I didn't have to follow the 
instructions in that thread. I just uncommented what's in site.xml:
   <pdfs label="PDFs" wholesite='false'>
     <whole_site_html label="Whole site HTML" href="wholesite.html" 
wholesite='false'/>
     <whole_site_pdf label="Whole site PDF" href="wholesite.pdf" 
wholesite='false'/>
   </pdfs>

(NOTE: My unsuccessful attempt at 'hiding' these links from the 
/wholesite.html & /wholesite.pdf. I also tried placing that with just 
the parent <pdfs label="PDFs" wholesite='false'>)

[1]
http://issues.apache.org/eyebrowse/ReadMsg?listId=260&msgNo=381

Web Maestro Clay
-- 
Clay Leeds - <cleeds@medata.com>
Webmaster/Developer - Medata, Inc. - <http://www.medata.com/>
PGP Public Key: <https://mail.medata.com/pgp/cleeds.asc>


Mime
View raw message