Just wondering, was this fix skin-specific?

I was having a similar problem creating a site under Tomcat (Tomcat 5.0.25).  I'm not sure if it is the same problem.

Using the new svn download can use 'forrest war' and deploy the seed app with the default skin. When I select the tigris skin, though I can still use 'forrest run' fine on my local machine, a deployed 'forrest war' version gives me an error screen with an unspecified xpath error.

In other words this sequence worked fine:
1. update svn
2. build forrest
3. seed a project
4. forrest war
5 deploy under Tomcat

this sequence then failed:
1. seed another project from updated svn above.
2. uncomment the tigris skin line in forrest.properties
3. forrest war
4. deploy under Tomcat

Any advice?

----- Forwarded by Peter Dykstra/USA/DDS on 09/08/2004 09:17 AM -----
"Hare, Michael" <Michael.Hare@fnc.fujitsu.com>

09/07/2004 12:53 PM
Please respond to

RE: Forrest 0.6 Interaction with Tomcat 5.0.27

I updated SVN to latest and rebuilt.

Nicola, you have successfully fixed the problem forrest was having seeding and building webapps

For better or for worse, though, we have come full circle with the issue.

[1] Forrest 0.6 builds fine.
[2] Forrest seeding completes without errors
[2] Forrest builds the site with the same error:
* [39/21]   [0/0]     0.06s  390b    skin/images/rc-t-r-15-1body-2menu-3menu.png
* [40/20]   [0/0]     4.627s 11.1Kb  images/project.png
* [41/23]   [4/31]    0.621s 21.8Kb  samples/document-v13.html
* [42/23]   [1/10]    0.09s  15.8Kb  samples/document-v13.xml
X [0]                                     samples/ext:dtd-docs  BROKEN: No pipeline matched request: samples/ext:dtd-docs
* [44/21]   [0/0]     0.02s  696b    images/icon.png
* [45/20]   [0/0]     20.98s 521b    changes.rss
* [46/19]   [0/0]     0.391s 12.8Kb  samples/document-v13.pod
* [47/18]   [0/0]     1.272s 7.4Kb   samples/sdocbook.pdf
* [48/17]   [0/0]     0.28s  6.5Kb
and the build fails, however..
[3] Forrest war completes without errors
[4] Forrest webapp completes without errors
[5] If I set up my Tomcat conf file for forrest 0.6 as indicated in the original problem, I can access forrest 0.6, I can also access the Cocoon samples.
[5a] I cannot access my Tomcat admin panel, any of the JSP/Servlet examples that shipped with Tomcat, or my Xindice install.
[6] If I remove the conf file for Forrest 0.6 from Tomcat, then I can access everything (except forrest 0.6, of course. I can still access forrest 0.5.1 as I did not remove that conf file.)

-----Original Message-----
From: Nicola Ken Barozzi [mailto:nicolaken@apache.org]
Sent: Tuesday, September 07, 2004 10:47 AM
To: user@forrest.apache.org
Subject: Re: Forrest 0.6 Interaction with Tomcat 5.0.27

Hare, Michael wrote:
> I commented out the DOCTYPE decl and added the validate=false entry into the properties file.
> I'm back to the Java ConnectException: Connection Timeout error

Try updating svn now and testing, I've put in what I believe could be a
fix without having to do either of the afromentioned actions.

Nicola Ken Barozzi                   nicolaken@apache.org
            - verba volant, scripta manent -
   (discussions get forgotten, just code remains)