forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krzysztof Porowski <K.Porow...@gmail.com>
Subject Forrest 0.6 menu generation
Date Wed, 29 Sep 2004 18:24:50 GMT
Hello!
I have some problems with js menu.
1.After switching (from 0.51) to forrest 0.6 (forrest_20040921165028)
I cannot get left js menu generated properly. I am using pelt skin.
Below there is a part of my index.html file. As you can see an <a> tag
has empty href attribute and text between <a> and </a> tags.

<!--+
    |start Menu
    +-->
<div id="menu">
<div onclick="SwitchMenu('menu_1.1', 'skin/')" id="menu_1.1Title"
class="menutitle"></div>
<div id="menu_1.1" class="menuitemgroup">
<div class="menuitem">
<a href=""></a>
</div>
<div class="menuitem">
<a href=""></a>
</div>
<div class="menuitem">
<a href=""></a>
</div>
</div>
<div onclick="SwitchMenu('menu_1.2', 'skin/')" id="menu_1.2Title"
class="menutitle"></div>
<div id="menu_1.2" class="menuitemgroup">
<div class="menuitem">
<a href=""></a>
</div>
<div class="menuitem">
<a href=""></a>
</div>
<div class="menuitem">
<a href=""></a>
</div>
<div class="menuitem">
<a href=""></a>
</div>
</div>
<div id="credit">
<a href="http://forrest.apache.org/"><img border="0" alt="Built with
Apache Forrest logo" src="images/built-with-forrest-button.png"
style="width: 88px;height: 31px;"></a>
</div>
<div id="roundbottom">
<img style="display: none" class="corner" height="15" width="15"
alt="" src="skin/images/rc-b-l-15-1body-2menu-3menu.png"></div>
<!--+
  |alternativ credits
  +-->
</div>
<!--+
    |end Menu
    +-->

2. I got only index.html and linkmap.html. Other files (like
changes.html, todo.html and my docs subdirectory with 4 more .xml
files) are not generated.

I suppose, that theese bugs are connected. I got the same strange
behaviour when I make 'forrest seed' and 'forrest'. The js menu is
broken also. So IMHO it's not my page fault.


Krzysztof

Mime
View raw message