forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabio Rinaldi" <rina...@ifi.unizh.ch>
Subject Re: Solaris problem
Date Fri, 06 Aug 2004 10:11:07 GMT

Hi David,

I tried with the latest tarball because I do not have svn (guess I
should install it). Is there a way to get the latest stable revision
without svn?

And yes, all the problems reported so far are on Solaris. The linux
version (0.5.1, binary) worked smoothly from the very beginning. For
the time being I can keep working with it, but I hope the Solaris
problems can be solved, because our web site runs on a Solaris
machine, so it is going to be much more convenient for us to work on
the same machine, rather than have to transfer everything from linux
each time a change is made to our web site.

Btw, I discovered the cause of the first of the two problems reported
below (trying to set FORREST_HOME in bin/forrest). Basically this piece of
code is using bash syntax which is not backward compatible with sh. On
default linux installations, /bin/sh is simply a link to /bin/bash,
but on Solaris it is not. My suggestion is to call explicitly

/bin/bash 

instead of /bin/sh in all shell scripts.

Fabio


David Crossley writes:
 > Sorry Fabio, that was bad timing. However it illustrates
 > the problem with working with the head development version.
 > You never know when it might be broken. It is today.
 > 
 > One of our committers made a fundamental change which
 > has errors. We will get straight onto it.
 > 
 > By the way, it would have been better to send this to
 > the mailing list rather than to me. Other developers
 > would then be alerted to today's problems.
 > 
 > The first issue that you mention below sounds like a bug.
 > Is that output from your Solaris?
 > 

Fabio Rinaldi wrote:
> Hi David,
> 
> I am trying with the development version (latest one:
> forrest_20040805110521.tar.gz). However I am running into a couple of
> problems. First I had to comment out the following in bin/forrest:
> 
> # use the location of this script to infer $FORREST_HOME
> # realpath_listing=$(ls -l $0)
> # realpath="${realpath_listing#*-> }"     # strip everything before '-> '
> # realpath="/${realpath#*/}"        # strip everything before '/' (in case there wasn't
a ->)
> # FORREST_HOME=`dirname "$realpath"`/..
> 
> Then 'forrest seed' works, but 'forrest site' ends with the following
> error:
> 
> ------------------------------------------------------------
> 
> fetch-skin:
> Processing [MYHOME]/forrest/src/core/context/skins/skins-1.xml to [MYHOME]/MYSITE/build/tmp/skinlist2fetchbuild.xml
> Loading stylesheet [MYHOME]/forrest/src/core/var/skinlist2fetch.xsl
> 
> fetch-versioned-skin:
> Trying to get "book-tab" skin version 
>                   0.6-dev...
> 
> BUILD FAILED
> [MYHOME]/forrest/src/core/targets/skins.xml:107: The following error occurred while executing
this line:
> [MYHOME]/forrest/src/core/targets/skins.xml:119: The following error occurred while executing
this line:
> [MYHOME]/MYSITE/build/tmp/skinlist2fetchbuild.xml:7: java.net.MalformedURLException:
no protocol: book-tab-0.6-dev.zip
> 
> Total time: 9 seconds
> ------------------------------------------------------------
> 
> I guess it is trying to find 'book-tab-0.6-dev.zip'. Where is it
> supposed to find it? And how do I specify it?
> 

Mime
View raw message