forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabio Rinaldi" <rina...@ifi.unizh.ch>
Subject Re: Solaris problem
Date Thu, 05 Aug 2004 11:50:11 GMT


David Crossley writes:
 > 
 > Either that or jump in and use the current development
 > version from SVN or from a "snapshot" tarball which you
 > get from http://forrest.apache.org/mirrors.cgi#svn
 > 

OK, I'll test the development version as well.

 > > 
 > > Yes, I think they are correct. I have installed Forrest in
 > > /opt/apache/forrest, so
 > > FORREST_HOME=/opt/apache/forrest
 > 
 > No that is an incorrect setting for FORREST_HOME
 > unless you did something strange and copied the generated
 > forrest shell scripts back into the top-level of the
 > Forrest source distribution. (You didn't specify, so i am
 > assuming that you are using the source distribution.)

I tried first the binary distribution, which I installed in
/opt/apache/forrest, but then (precisely because it
gave me the same problem), I downloaded and compiled the source
distribution. Then I removed the original binary distribution and
copied in the same place the results of compilation, following the
advice obtained at the end of the compilation process.

 > Do './build.sh' again and read the instructions. Sorry the
 > message at the end is a bit confusing, as you do not need
 > to copy anything.
 >
 > This is the setting that I have
 > FORREST_HOME=/usr/local/cvs/forrest-stable/xml-forrest/build/dist/shbat
 > 
 > My Forrest distribution is in
 > /usr/local/cvs/forrest-stable/xml-forrest
 
OK, I have now recompiled the source distribution (in my home dir),
and set

FORREST_HOME=[..MYHOME..]/apache-forrest-0.5.1-src/build/dist/shbat/
$PATH=$FORREST_HOME/bin:$PATH

Then I recreated from scratch the 'seed' web site, but I get again the
same error when I run 'forrest site':

------------------------------------------------------------

* [0]   2.83s  766b    favicon.ico
* [0]   1.304s 0b      index.html
X [0]                       index.html  BROKEN: URI not found
Total time: 0 minutes 12 seconds

BUILD FAILED
[...MYHOME...]/apache-forrest-0.5.1-src/build/dist/shbat/forrest.build.xml:631: Java returned:
1

------------------------------------------------------------

I will now try with the development version and then report the
outcome.

Fabio

Mime
View raw message