forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Pelt has a bug ** Retraction ??
Date Fri, 20 Aug 2004 00:58:19 GMT
Leeman Strout wrote:
> Ok, strike the below...

Please do not keep changing the email subject line.
That makes it difficult to follow your issue.

Also be careful about addressing two issues in the
one subject. Your secondary issue could easily be
overlooked. (Anyway, see below at end.)

> My best guess is that I got struck by a strange reload issue with Firefox.
> 
> Breadcrumbs disappeared for me after I did the following:  rendered 
> pelt, then rendered with crust, then rendered pelt again...
> 
> I had re-rendered pelt several times with the corrected <link> 
> properties, and reloaded (Shift-reload) in Firefox several times.  I 
> also reloaded between each step above, and then suddenly they disappear?
> 
> Mind you crust also had the breadcrumbs rendering.
> 
> How strange.

You should do 'forrest clean' between these runs.
Also when you are doing local testing be careful about
the cache settings of your browser.

> Leeman Strout wrote:
> 
> > Sorry about that...
> > 
> > To continue:
> > 
> > Lastly, I can't get pelt to not display breadcrumbs.  I have changed 
> > within skinconf.xml the following:
> > 
> >   <trail>
> >     <link1 name="" href=""/>
> >     <link2 name="" href=""/>
> >     <link3 name="" href=""/>
> >   </trail>
> > 
> > And I still get the breadcrumbs.  And in fact I just tested and it may 
> > not be just pelt... but I don't know where it would be.  pelt and crust 
> > both display breadcrumbs no matter how I change the above.
> > 
> > So how do you *really* get breadcrumbs to go away?
> > 
> > 
> > Thanks,
> > Leeman
> > 
> > Leeman Strout wrote:
> > 
> >> I'm attempting to work with the pelt skin to get it to look how I'd like.
> >>
> >> Firstly, is it possible to put in a little helper line for 
> >> skinconf.xml for the TOC entry?  I had set max/min to 0 (similar to 
> >> Forrest 0.5) expecting the TOC to disappear.  Well it did, but the 
> >> <UL> was still there.  I randomly tried setting everything to "", and

> >> it worked.
> >>
> >> Secondly, how can I put in custom CSS for a skin?  In the pelt skin 
> >> I'd like the tabs to NOT be all CAPS.  This should be a simple thing, 
> >> right?  It'd would be nice if it were a simple matter of sticking this:
> >>
> >> #tabs li a {
> >>    text-transform: none;
> >> }
> >>
> >> into some file inside my project (which file is hopefully the nice 
> >> simple answer for me).

That is now fixed. Thanks for reporting.
The file in question was pelt/css/screen.css
The "uppercase" line was removed. People can specify
uppercase labels in tabs.xml if that is what they want.

-- 
David Crossley


Mime
View raw message