forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Forrest 0.6 Interaction with Tomcat 5.0.27
Date Tue, 10 Aug 2004 04:04:24 GMT
Hare, Michael wrote:
> I'm seeing odd behavior when I try to use the forrest from svn.

I do not run Tomcat so cannot help much. However, we need to keep
your issue near the top of the pile.

Some suggestions below ...

> I compile on Windows XP, I have Apache 2.0.50 + Tomcat 5.0.27 + JK2 2.0.4
> I stopped using Cygwin because it was introducing it's own set of issues.

Sorry, what is JK2?

> I keep my local image updated using: 'svn update', then 'build clean' the
> 'build'
> 
> I can seed, build and deploy a webapp.. no problems so far.
> 
> I connect Tomcat to the Forrest site with this configuration file:
> 
> <Context path="/ForrestExamples" docBase="C:\Forrest\build\webapp" debug="0"
> reloadable="true">
>    <Logger className="org.apache.catalina.logger.FileLogger" debug="0"
> verbosity="1" prefix="forrest_demo_log." directory="logs" timestamp="true"
> suffix=".txt"/>
> </Context>
> 
> I have copied over the endorsed libraries in to Tomcat's endorsed directory.
>
> I can even access the Forrest Site from Tomcat.
> 
> The problem is once I put the configuration file into Tomcat's
> catalina/localhost directory, I can no longer access several other of my
> other applications such as Xindice, or the JSP and Servlet examples that
> ship with Tomcat. I can't even access the Tomcat Home Page using
> http://myurl.com:8080

When you say "put the configuration file" are you adding the above
fragment to an existing configuration file, or are you totally
replacing a configuration file, or what? Our instructions from
the 'forrest webapp' or 'forrest war' say to add that to server.xml
Are our instructions out-of-date?

--David

> I get HTTP Status 503 (Application Not Currently Available) for each of
> these
> 
> Oddly enough, I can still access Cocoon 2.1.5.1 samples, Axis sample page
> and the eXist XMLDB sample page.
>
> Here's a few lines from my stdout.log file that are not there when all is
> working.:
> 
> ...
> ...
> ...
> INFO: Processing Context configuration file URL
> file:C:\Programs\ApacheGroup\Tomcat5\conf\Catalina\localhost\manager.xml
> Aug 4, 2004 10:03:03 AM org.apache.catalina.startup.ContextConfig
> authenticatorConfig
> SEVERE: Cannot instantiate an authenticator of class
> org.apache.catalina.authenticator.BasicAuthenticator
> java.lang.ExceptionInInitializerError
> 	at java.lang.Class.forName0(Native Method)
> 	at java.lang.Class.forName(Class.java:141)
> ...
> ...
> ...
> 
> If I remove the Forrest site configuration file, and restart Tomcat, then
> all is fine, except I can't access the Forrest Site without the config file.
> If I copy the config file back to Tomcat, go to the Tomcat admin panel and
> 'start' Forrest, everything is fine. I can access my Forrest site and the
> Tomcat home page.
> If I stop then start Tomcat, it breaks again.
> 
> This is very localized to the 0.6 Forrest install.
> 
> If I swap back to using forrest 0.5.1 (%FORREST_HOME%, 0.5.1 endorsed libs,
> etc..), then I don't have any problems at all.
> 
> Any one have any experience with any of this?
> ---------------------------------
> Michael Hare
> 
> GnuPG Key fingerprint = 1AD4 726D E359 A31D 05BF  ACE5 CA93 7AD5 D8E3 A876



Mime
View raw message