forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Solaris problem
Date Fri, 06 Aug 2004 14:17:45 GMT
Fabio Rinaldi wrote:
> Hi David,

No need to Cc me, i am on the lists.

> I tried with the latest tarball because I do not have svn (guess I
> should install it).

Yeah, you will love it. The command-line client is so easy.

> Is there a way to get the latest stable revision
> without svn?

This concept of stable revision in a 0.* release
is something that i just invented to get us through
this phase when the head is broken. There are certain
times when the head is less stable, but it is always
unstable.

I am going to revert the recent changes, then today's
snapshots will be fine. The first will be 4 hours away.
get it from http://forrest.apache.org/mirrors.cgi

(We should actually do that final phase of development
on a branch.)

However remember that snapshots are automatically
generated at a certain time, while Forrest is quickly
evolving. Better to install svn.

> And yes, all the problems reported so far are on Solaris. The linux
> version (0.5.1, binary) worked smoothly from the very beginning. For
> the time being I can keep working with it, but I hope the Solaris
> problems can be solved, because our web site runs on a Solaris
> machine, so it is going to be much more convenient for us to work on
> the same machine, rather than have to transfer everything from linux
> each time a change is made to our web site.

I wonder if it is a UNIX shell issue ... csh versus bash?
Oh, then i read on.

> Btw, I discovered the cause of the first of the two problems reported
> below (trying to set FORREST_HOME in bin/forrest). Basically this piece of
> code is using bash syntax which is not backward compatible with sh. On
> default linux installations, /bin/sh is simply a link to /bin/bash,
> but on Solaris it is not.

We were trying to keep agnostic. That piece of code was
a recent addition.

> My suggestion is to call explicitly
> 
> /bin/bash 

However, bash might not be on all UNIX systems.

More below ...

> instead of /bin/sh in all shell scripts.
> 
> Fabio
> 
> 
> David Crossley writes:
>  > Sorry Fabio, that was bad timing. However it illustrates
>  > the problem with working with the head development version.
>  > You never know when it might be broken. It is today.
>  > 
>  > One of our committers made a fundamental change which
>  > has errors. We will get straight onto it.
>  > 
>  > By the way, it would have been better to send this to
>  > the mailing list rather than to me. Other developers
>  > would then be alerted to today's problems.
>  > 
>  > The first issue that you mention below sounds like a bug.
>  > Is that output from your Solaris?
>  > 
> 
> Fabio Rinaldi wrote:
> > Hi David,
> > 
> > I am trying with the development version (latest one:
> > forrest_20040805110521.tar.gz). However I am running into a couple of
> > problems. First I had to comment out the following in bin/forrest:
> > 
> > # use the location of this script to infer $FORREST_HOME
> > # realpath_listing=$(ls -l $0)
> > # realpath="${realpath_listing#*-> }"     # strip everything before '-> '
> > # realpath="/${realpath#*/}"        # strip everything before '/' (in case there
wasn't a ->)
> > # FORREST_HOME=`dirname "$realpath"`/..
> > 
> > Then 'forrest seed' works, but 'forrest site' ends with the following
> > error:

I think that the rest of your issue might be because you had
an old snapshot, lets see after today.

-- 
David Crossley


Mime
View raw message