forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Schlierf, Stephan" <Stephan.Schli...@VSA.de>
Subject AW: "site:myfile#anchor" links don't work
Date Tue, 06 Jul 2004 10:31:51 GMT
> -----Urspr√ľngliche Nachricht-----
> Von: Johannes Schäfer [mailto:johannes.schaefer@uidesign.de]
> Gesendet: Dienstag, 6. Juli 2004 11:53
> An: user@forrest.apache.org
> Betreff: AW: "site:myfile#anchor" links don't work
> 
> 
> > Yes and no. In site.xml you have to define something like:
> > <myfile label="My File" href="myfile.html">
> >   <myanchor href="#an_anchor"/>
> > </myfile>
> 
> This works but gives menu entries in the tabs
> another level of hierarchy (using krysalis)
> for the files which have a anchor-reference,
> i.e. "myfile" gets a ">" mark to open or close
> the sublevels below, here "myanchor" only.
> (<toc level="2"/> in skinconf.xml)

Hm, you mean you have something like
My file (bold)
  myanchor
in your menu ?

Normally you get this by something like
<myfile label="My File">
  <myanchor label="My anchor" href="myanchor.html"/>
</myfile>
in site.xml.
Can you have a look at the definition in your site.xml again ?
It should be like I wrote before:
<myfile label="My File" href="myfile.html">
  <myanchor href="#an_anchor"/>
</myfile>

BTW: I use Forrest 0.5.1 and krysalis site, too.
As far as I know, the <toc level="2"/> element in skinconf.xml
only affects the depth of the table of contents at the beginning of each
site.

Stephan

Mime
View raw message