forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Schlierf, Stephan" <Stephan.Schli...@VSA.de>
Subject AW: "site:myfile#anchor" links don't work
Date Tue, 06 Jul 2004 08:21:33 GMT
> -----Ursprüngliche Nachricht-----
> Von: Johannes Schäfer [mailto:johannes.schaefer@uidesign.de]
> Gesendet: Dienstag, 6. Juli 2004 10:14
> An: user@forrest.apache.org
> Betreff: "site:myfile#anchor" links don't work
> 
> 
> Hi!
> 
> now it seems that I cannot use the #anchor
> references anymore?!
> Error message is
>   Invalid XPath: '/site//myfile#anchor/@href'. 
>   Invalid symbol '#' after: '/site//myfile'
> Is this not allowed?!

Yes and no. In site.xml you have to define something like:
<myfile label="My File" href="myfile.html">
  <myanchor href="#an_anchor"/>
</myfile>

Now you can refer to "myanchor" via <link href="site:myanchor></link>.
Be sure to have an anchor named "an_anchor" in your "myfile.xml".

HTH,
Stephan


> 
> Cheers
> Johannes
> 
> 
> > -----Ursprüngliche Nachricht-----
> > Von: Johannes Schäfer [mailto:johannes.schaefer@uidesign.de] 
> > Gesendet: Dienstag, 6. Juli 2004 09:15
> > An: user@forrest.apache.org
> > Betreff: Re: <link href="site:myfile"> doesn't work (for me)
> > 
> > 
> > Thanks!
> > 
> > I got something really wrong and put always the same 
> > tag into site.xml, like
> > 
> > <contents label="contents" href="contents/" ...>
> >   <contents label="myfile" href="myfile.html" .../>
> >   <contents label="mystuff" href="mystuff.html" .../>
> > </contents>
> > 
> > Changed it. Guess it works now :-)   
> > right, it works. Thank you!
> > 
> > Johannes
> > 
> > 
> > -----Ursprüngliche Nachricht-----
> > Von: Thorsten Scherler 
> > [mailto:thorsten.scherler.ext@juntadeandalucia.es] 
> > Gesendet: Dienstag, 6. Juli 2004 09:02
> > An: user@forrest.apache.org
> > Betreff: Re: <link href="site:myfile"> doesn't work (for me)
> > 
> > 
> > David Crossley wrote:
> > 
> > >Johannes Schäfer wrote:
> > >  
> > >
> > >>I can't get <link href="site:myfile"> working.
> > >>
> > >>It simply gives me e.g.
> > >>  <p>See <a href="site:myfile">myfile</a></p>
> > >>in the generated HTML.
> > >>
> > >>Any ideas?
> > >>    
> > >>
> > >
> > >Do you have "myfile" defined in your site.xml ?
> > >
> > >  
> > >
> > like
> > <site>
> > <something>
> >  <myfile href="myfile.html" label="myfile"/>
> > </something>
> > <more>
> >     <yourfile/>
> > </more>
> > </site>
> > 
> > HTH
> > thorsten
> > 
> > -- 
> > Thorsten Scherler
> > 
> > Departamento de Desarrollo de Proyectos
> > Sociedad Andaluza para el Desarrollo de la Sociedad de la 
> > Información S.A.U.
> > 
> > 
> > 
> > 
> > 
> 

Mime
View raw message