forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: sDocBook: figure-XSL broken?! (was: <figure> and images)
Date Thu, 22 Jul 2004 10:15:16 GMT
Thanks to both for your issue report. It would really help
at this stage if either Johannes or Christian could add
a report to our issue tracker. Maybe there is still time
to fix this before the upcoming release. Just add a very brief
description to the issue and link to this email thread.
There is no need to repeat it all.

Even better would be to look at the stylesheet
src/core/context/resources/stylesheets/docbook2document.xsl
and see if you can fix it. You would learn a lot about using
Forrest on the way.

Bear in mind, our FAQ about the limitations of DocBook handling.

If you don't manage any of this, then someone else will try.

--David

Johannes Schäfer wrote:
> Hi!
> Anybody using DocBook with forrest?
> 
> The <figure> and subsequent tags seem to miss some HTML bit 
> in XSL tanslation.
> 
> This docbook-code
>   > <figure id="testfig3"><title>Test Figure</title>
>   > <mediaobject>
>   > 	<imageobject>
>   > 		<imagedata fileref="images/image.png" format="PNG"/>
>   > 	</imageobject>
>   > </mediaobject>
>   > </figure>
> produces something like
>   <table class="ForrestTable" cellspacing="1" cellpadding="4">
>   <tr>
>     <td>Test Figure</td>
>   </tr>
> 		
>   <table class="ForrestTable" cellspacing="1" cellpadding="4">
>   <tr>
>     <td><img alt="" src="images/image.png"></td>
>   </tr>
>   </table>
> 
>   </table>
> So, the inner table is somewhat misplaced.
> The DokBook list said that for them the code works fine 
> w/o any problems (see also code below).
> 
> We could not find the XSL files for formatting DocBook
> in forrest to change it. Where can we find them?! 
> Any suggestion of how to fix this?
> 
> Additionally the <inlinemediaobject> does not get translated
> to HTML but appears literally in the html file.
> 
> Cheers
> Johannes & Christian
> 
> 
> 
> > -----Original Message-----
> > From: Christian Kaspari [mailto:christian.kaspari@uidesign.de] 
> > Sent: Wednesday, July 21, 2004 2:56 PM
> > To: user@forrest.apache.org
> > Subject: <figure> and images
> > 
> > 
> > Hi everybody,
> > 
> > at first I have to say, that I´m new to Forrest and XML, so please be
> > patient if this question is a rather dumb one... ;-)
> > I´m using the Forrest Developmental Version 0.6 and the 
> > simplified DocBook
> > and I`ve got problems with images in <figure>-Tags. As long 
> > as the figure
> > Tag consists of plain Text, everything works fine, but if it 
> > consists of an
> > image(see the example below), the following tags aren´t 
> > displayed in their
> > normal format (text size, alignment, etc...).
> > 
> > Thanks for your help!
> > 
> > Christian Kaspari
> > 
> > 
> > This is the test-code:
> > 
> > ####################################################
> > 
> > <!DOCTYPE article PUBLIC "-//OASIS//DTD Simplified DocBook 
> > XML V1.0//EN"
> > "http://www.oasis-open.org/docbook/xml/simple/1.0/sdocbook.dtd">
> > 
> > <article>
> > 
> > <title>Article Test Document Title</title>
> > 
> > <figure id="testfig3"><title>Test Figure</title>
> > <mediaobject>
> > 	<imageobject>
> > 		<imagedata fileref="images/image.png" format="PNG"/>
> > 	</imageobject>
> > </mediaobject>
> > </figure>
> > 
> > <para>
> > This is a <quote>short quote</quote>.
> > This is a <quote>Quotation with a <quote>nested quotation
> > containing a <quote>nested quotation and another <quote>nested
> > quotation</quote></quote></quote></quote>.
> > </para>
> > 
> > <figure id="testfig1"><title>Test Figure</title>
> > <programlisting>This is a
> >   ProgramListing
> > </programlisting>
> > </figure>
> > 
> > </article>
> > 
> > ####################################################
> > 
> > 


Mime
View raw message