forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maria Jones <jonesfamily2...@bellsouth.net>
Subject DTD Complication
Date Fri, 18 Jun 2004 00:22:22 GMT
I have done a new installation of forrest from CVS. I have previous 
documentation using various other dtds namely Oasis, SuSE, and KDE. The 
configuration of forrest validates good for the Oasis doc's however both KDE 
and SuSE are having issues.

Here's my take:
Oasis is using the included docbookx.dtd as configured. By default --- very 
nice!

I have included the SuSE dtd in the catalog.xcat file as instructed. Thus:

....

<public publicId="-//SuSE//DTD DocBook XML V4.2-Based Subset 0.1//EN"
        uri="susedtd/0.2.3/susex.dtd"/>
<public publicId="-//SuSE//DTD DocBook XML V4.2-Based Variant 0.1//EN"
        uri="susedtd/0.2.3/susex.dtd"/>

<public publicId="-//SuSE//ENTITIES DocBook HTML Additional General Entities 
V4.2//EN"
        uri="susedtd/0.2.3/susex.dbgenent-html.mod"/>
<public publicId="-//SuSE//ENTITIES DocBook LATEX Additional General Entities 
V4.2//EN"
        uri="susedtd/0.2.3/susex.dbgenent-latex.mod"/>
<public publicId="-//SuSE//ENTITIES DocBook Additional General Entities 
V4.2//EN"
        uri="susedtd/0.2.3/susex.dbgenent.mod"/>
<public publicId="-//SuSE//ENTITIES DocBook International Entities V4.2//EN"
        uri="susedtd/0.2.3/susex.i10n.mod"/> 
....

I have placed the dtd and modules into the 
${forrest_root}/src/core/context/resources/schema/ directory. And the 
appropriate files are located in the sub-directories as specified. 

If i open up my test xml file in kate, and validate against the local dtd; all 
seems good to go. I've tried it with using the original dtd's from my root 
( /usr/share/xml/docbook/custom/susedtd/0.2.3/schema/dtd/susex.dtd ), and/or 
the forrest copy 
( ${forrest_root}/src/core/context/resources/schema/susedtd/0.2.3/susex.dtd ) 
---- shouldn't matter but both validate ok when specified.

File DOCTYPE is as follows:

....
<!DOCTYPE book PUBLIC "-//SuSE//DTD DocBook XML V4.2-Based Variant 0.1//EN" 
"/usr/share/xml/docbook/custom/susedtd/0.2.3/schema/dtd/susex.dtd" []>
....

So i included my test file in site.xml. As such:

....
<susex label="SuSE Docbook" href="test-susex.html" description="SuSE 
example" />
....

Enter my website root of test site. Now i run 'forrest validate' ---- BUILD 
SUCCESSFUL. Then  i run 'forrest' ---- BUILD SUCCESSFUL again.

So i navigate to my "new" page and voila! No content? What am i missing?

Thanks for your time.

Mime
View raw message