forrest-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: DTD Complication
Date Fri, 18 Jun 2004 02:00:58 GMT
Maria Jones wrote:
> I have done a new installation of forrest from CVS.

I hope that you are aware that Forrest does not use CVS
anymore. If you are using CVS, then you are using very
old sources. http://forrest.apache.org/faq.html#cvs

More below.

> I have previous 
> documentation using various other dtds namely Oasis, SuSE, and KDE. The 
> configuration of forrest validates good for the Oasis doc's however both KDE 
> and SuSE are having issues.
>
> Here's my take:
> Oasis is using the included docbookx.dtd as configured. By default --- very 
> nice!
> 
> I have included the SuSE dtd in the catalog.xcat file as instructed. Thus:
> 
> ....
> 
> <public publicId="-//SuSE//DTD DocBook XML V4.2-Based Subset 0.1//EN"
>         uri="susedtd/0.2.3/susex.dtd"/>
> <public publicId="-//SuSE//DTD DocBook XML V4.2-Based Variant 0.1//EN"
>         uri="susedtd/0.2.3/susex.dtd"/>
> 
> <public publicId="-//SuSE//ENTITIES DocBook HTML Additional General Entities 
> V4.2//EN"
>         uri="susedtd/0.2.3/susex.dbgenent-html.mod"/>
> <public publicId="-//SuSE//ENTITIES DocBook LATEX Additional General Entities 
> V4.2//EN"
>         uri="susedtd/0.2.3/susex.dbgenent-latex.mod"/>
> <public publicId="-//SuSE//ENTITIES DocBook Additional General Entities 
> V4.2//EN"
>         uri="susedtd/0.2.3/susex.dbgenent.mod"/>
> <public publicId="-//SuSE//ENTITIES DocBook International Entities V4.2//EN"
>         uri="susedtd/0.2.3/susex.i10n.mod"/> 
> ....
> 
> I have placed the dtd and modules into the 
> ${forrest_root}/src/core/context/resources/schema/ directory. And the 
> appropriate files are located in the sub-directories as specified. 
> 
> If i open up my test xml file in kate, and validate against the local dtd; all 
> seems good to go. I've tried it with using the original dtd's from my root 
> ( /usr/share/xml/docbook/custom/susedtd/0.2.3/schema/dtd/susex.dtd ), and/or 
> the forrest copy 
> ( ${forrest_root}/src/core/context/resources/schema/susedtd/0.2.3/susex.dtd ) 
> ---- shouldn't matter but both validate ok when specified.

The way that you have configured this will still work,
but is not advisable. You should not mess with the Forrest
source itself. You say "as advised", but i do not think
that our documentation says to add to Forrest's internal
catalog.

You can provide a dedicated catalog.xcat for your project. 
See below.

The current head version of SVN has even better ways to
configure your local DTDs.

> File DOCTYPE is as follows:
> ....
> <!DOCTYPE book PUBLIC "-//SuSE//DTD DocBook XML V4.2-Based Variant 0.1//EN" 
> "/usr/share/xml/docbook/custom/susedtd/0.2.3/schema/dtd/susex.dtd" []>
> ....
> 
> So i included my test file in site.xml. As such:
> 
> ....
> <susex label="SuSE Docbook" href="test-susex.html" description="SuSE 
> example" />
> ....
> 
> Enter my website root of test site. Now i run 'forrest validate' ---- BUILD 
> SUCCESSFUL. Then  i run 'forrest' ---- BUILD SUCCESSFUL again.

The DTD configuration and validation is obviously
working then.

> So i navigate to my "new" page and voila! No content? What am i missing?

You need to follow the document "Using Forrest" your-project.html
It describes the steps to deal with a new document type.
It sounds like you have not added a "sitemap" to your project
which is needed to detect your new document type.

By the way, do not expect Forrest to deal with all possible
DocBook elements, especially extensions.
See http://forrest.apache.org/faq.html#docbook

I hope that helps. If not then keep asking questions.

--David



Mime
View raw message