forrest-svn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cross...@apache.org
Subject svn commit: r688022 - /forrest/branches/update_cocoon_2.1.12-dev/main/webapp/WEB-INF/xconf/forrest-core.xconf
Date Fri, 22 Aug 2008 08:46:01 GMT
Author: crossley
Date: Fri Aug 22 01:46:01 2008
New Revision: 688022

URL: http://svn.apache.org/viewvc?rev=688022&view=rev
Log:
Synchronise "XSP block" with Cocoon-2.1 xconf. Added new parameters "attr-interpolation" and
"text-interpolation".

Modified:
    forrest/branches/update_cocoon_2.1.12-dev/main/webapp/WEB-INF/xconf/forrest-core.xconf

Modified: forrest/branches/update_cocoon_2.1.12-dev/main/webapp/WEB-INF/xconf/forrest-core.xconf
URL: http://svn.apache.org/viewvc/forrest/branches/update_cocoon_2.1.12-dev/main/webapp/WEB-INF/xconf/forrest-core.xconf?rev=688022&r1=688021&r2=688022&view=diff
==============================================================================
--- forrest/branches/update_cocoon_2.1.12-dev/main/webapp/WEB-INF/xconf/forrest-core.xconf
(original)
+++ forrest/branches/update_cocoon_2.1.12-dev/main/webapp/WEB-INF/xconf/forrest-core.xconf
Fri Aug 22 01:46:01 2008
@@ -796,6 +796,15 @@
     <xsp-language logger="core.markup.xsp" name="xsp">
       <parameter name="prefix" value="xsp"/>
       <parameter name="uri" value="http://apache.org/xsp"/>
+      <!--+
+          | These two flags determine whether XSP expression interpolation
+          | shall take place in attribute values and text nodes, respectively.
+          | The syntax {#expr} has been chosen that a clash with existing
+          | XSPs and logicsheets is unlikely.  The possibility to switch these
+          | features off is here only for safety.
+          +-->
+      <parameter name="attr-interpolation" value="true"/>
+      <parameter name="text-interpolation" value="true"/>
 
       <!--+
           | Properties for the java language
@@ -959,11 +968,11 @@
   <programming-languages>
     <java-language logger="core.language.java" name="java">
 
-      <!-- Specifies which formatter to use to format source code.
-           This parameter is optional.
-           It is commented out because of bug #5689: Java "code-formatter"
-           incorrectly formats double values -->
-      <!--parameter name="code-formatter" value="org.apache.cocoon.components.language.programming.java.JstyleFormatter"/-->
+      <!--+ Specifies which formatter to use to format source code.
+          | This parameter is optional.
+          | At the moment there is no implementation of a code formatter available.
+          +-->
+      <!--parameter name="code-formatter" value="org.apache.cocoon.components.language.programming.java.NullFormatter"/-->
 
       <!-- A singleton-like implementation of a ClassLoader -->
       <parameter name="class-loader" value="org.apache.cocoon.components.classloader.ClassLoaderManagerImpl"/>
@@ -971,23 +980,37 @@
       <!--+
           | Specifies which Java compiler to use. Possible variants are:
           |
+          |  - EclipseJavaCompiler: the Eclipse JDT java compiler
           |  - Javac: the java compiler that comes with JDK
-          |  - Pizza: the Pizza java compiler
           |  - Jikes: the Jikes java compiler
-          |  - EclipseJavaCompiler: the Eclipse JTD java compiler
+          |  - Pizza: the Pizza java compiler (deprecated. Support will be removed in 2.2)
           |
-          | NOTE: the Eclipse JTD is the only java compiler that is capable
+          | NOTE: the Eclipse JDT is the only java compiler that is capable
           |       of imports classes thru the context classloader. All other
           |       compilers import classes from the JVM classpath and might
           |       normally result in ClassNotFound problems at compilation
           |       time. It is *HIGHLY* suggested that you use this compiler
           |       or you might experience problems in some servlet containers.
           +-->
+      <parameter name="compiler" value="org.apache.cocoon.components.language.programming.java.EclipseJavaCompiler"/>
       <!--parameter name="compiler" value="org.apache.cocoon.components.language.programming.java.Javac"/-->
-      <!--parameter name="compiler" value="org.apache.cocoon.components.language.programming.java.Pizza"/-->
       <!--parameter name="compiler" value="org.apache.cocoon.components.language.programming.java.Jikes"/-->
-      <parameter name="compiler" value="org.apache.cocoon.components.language.programming.java.EclipseJavaCompiler"/>
+      <!--parameter name="compiler" value="org.apache.cocoon.components.language.programming.java.Pizza"/-->
<!-- deprecated-->
 
+      <!--+
+          | Specifies the java code source version used to compile the XSP code.
+          |
+          | Posible values:
+          | 1.3 = Java version 1.3 
+          | 1.4 = Java version 1.4
+          | 1.5 = Java version 1.5
+          | auto = The version of the JVM where cocoon is running. (Default value).
+          |
+          | NOTE: The parameter is optional to keep backward compatibility.
+          |       The parameter works with Sun Javac compiler and the Eclipse compiler.
+          |       The pizza compiler does not support java 1.5.
+          +-->
+      <!-- <parameter name="compiler-compliance-level" value="auto"/> -->
     </java-language>
 
     <!-- Interpreted JavaScript language -->



Mime
View raw message