forrest-svn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rgard...@apache.org
Subject svn commit: r161293 - forrest/trunk/site-author/content/xdocs/docs/plugins/pluginInfrastructure.xml
Date Thu, 14 Apr 2005 14:11:10 GMT
Author: rgardler
Date: Thu Apr 14 07:11:09 2005
New Revision: 161293

URL: http://svn.apache.org/viewcvs?view=rev&rev=161293
Log:
update naming convention

Modified:
    forrest/trunk/site-author/content/xdocs/docs/plugins/pluginInfrastructure.xml

Modified: forrest/trunk/site-author/content/xdocs/docs/plugins/pluginInfrastructure.xml
URL: http://svn.apache.org/viewcvs/forrest/trunk/site-author/content/xdocs/docs/plugins/pluginInfrastructure.xml?view=diff&r1=161292&r2=161293
==============================================================================
--- forrest/trunk/site-author/content/xdocs/docs/plugins/pluginInfrastructure.xml (original)
+++ forrest/trunk/site-author/content/xdocs/docs/plugins/pluginInfrastructure.xml Thu Apr
14 07:11:09 2005
@@ -132,15 +132,13 @@
         <p>The name should be structured like a java package name, and should
         include a relevant reverse domain name. For example:</p>
         
-        <source>org.apache.forrest.plugin.PLUGINNAME</source>
-        <source>net.sf.forrestPlugins.PLUGINNAME</source>
+        <source>org.apache.forrest.plugin.PLUGIN_TYPE.PLUGIN_NAME</source>
+        <source>net.sf.forrestPlugins.PLUGIN_TYPE.PLUGIN_NAME</source>
         
-        <p>In addition the name of the plugin should indicate the type of plugin
-        it is:</p>
+        <p>Where <code>PLUGIN_TYPE</code> is either "internal", "input"
or
+        "output" and <code>PLUGIN_NAME"</code> is a suitable name chosen by
+        yourself.</p>
         
-        <source>NAME-input</source>
-        <source>NAME-output</source>
-        <source>NAME-internal</source>
       </section>
       
       <section>



Mime
View raw message