forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Customizing a website using forrest 0.10-dev and dispatcher
Date Fri, 12 Sep 2014 09:03:01 GMT
On Fri, Sep 12, 2014 at 10:08:28AM +0200, Vicent Mas wrote:
> On Fri, Sep 12, 2014 at 1:29 AM, David Crossley <crossley@apache.org> wrote:
> > On Thu, Sep 11, 2014 at 06:52:28PM +0200, Vicent Mas wrote:
> >> On Thu, Sep 11, 2014 at 5:09 PM, David Crossley <crossley@apache.org>
wrote:
> >> > On Thu, Sep 11, 2014 at 01:48:58PM +0200, Vicent Mas wrote:
> >> >> Hi,
> >> >>
> >> >> I'm trying to build a website with forrest 0.10 and the dispatcher
> >> >> plugin. My current problem is that all my customizations are ignored.
For
> >> >> instance, if I change the copyright in a footer it is not updated.
I've used
> >> >> the Dispatcher Quickstart (version 0.8 is the most modern version I
found) as
> >> >> a guide when possible.
> >> >
> >> > Not sure what you mean regarding "version 0.8".
> >>
> >> I mean this document:
> >>
> >> http://forrest.apache.org/pluginDocs/plugins_0_80/org.apache.forrest.plugin.internal.dispatcher/how/howto-dispatcher-quickstart.html
> >
> > Ah. When using the "dev" version of Forrest, should use the local docs.
> >
> >> > The current, but perhaps out-of-date, document is in the plugin's docs.
> >> > Do this:
> >> >  cd whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher
> >> >  forrest run
> >> >  http://localhost:8888/how/howto-dispatcher-quickstart.html
> >>
> >> I've done it but I get a "Resource not found error".
> >
> > That is very strange. It works locally for me.
> >
> > Perhaps you need to clean your Forrest setup.
> > (Of course replace with Windows-specific commands.)
> >  cd $FORREST_HOME/main
> >  ./build.sh clean
> >  ./build.sh
> >
> > Not sure what is needed to clean the Dispatcher plugin,
> > so do this:
> >  cd $FORREST_HOME/whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher
> >  forrest clean
> >  $FORREST_HOME/tools/ant/bin/ant clean
> >
> > Then do:
> >  forrest run
> > which should automatically build and deploy the Dispatcher plugin,
> > and the other plugins that it uses, from the local dev sources.
> > During that process the "get-local" Ant task should be indicating
> > that it is using the local sources.
> 
> No luck. I keep getting a "Resource not found error".

Okay. That might be due to its use of the projectInfo plugin
which we think might need tweaking as indicated in FOR-1188.

> >> Anyway I've found
> >> the xml version of the document and the content seems to correspond to
> >> the document I mention above. The document talks about an
> >> org.apache.forrest.themes.core plugin that I'm unable to find and also
> >> about a pelt.fv file in that plugin, so I am lost.
> >
> > Yes, because no-one has managed to update those docs yet.
> 
> I see.
> 
> > As Sjur explained that old supporting plugin is not used anymore.
> 
> I don't use that plugin. As I said I used the quickstart document as a
> guide only when possible. IIRC my hierarchy of folders was built
> imitating the contents of the dispatcher plugin folder regarding
> themes.
>
> >> > (Patches welcome :-)
> >>
> >> I wish I was able to patch it :-) Thanks once more for your help.
> >>
> >> > I am hoping that someone who knows more can help you with
> >> > the rest, e.g. Thorsten, Cyriaque, Brian, etc.
> 
> I hope so. As I said I'm really stuck.

In the meantime you might be able to determine where the
Dispatcher is looking for those project resources by investigating
the various *.xmap sitemaps in the top-level of the Dispatcher
plugin and its locationmap.xml file.

There are some debugging techniques listed here:
http://forrest.apache.org/howto-dev.html
and the link to the FAQ
http://forrest.apache.org/docs_0_100/faq.html#version
to report all "properties" to help with following those sitemaps.

-David

Mime
View raw message