forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Building my website with forrest 0.9
Date Thu, 11 Sep 2014 08:31:09 GMT
On Thu, Sep 11, 2014 at 10:54:29AM +1000, David Crossley wrote:
> On Wed, Sep 10, 2014 at 11:23:07AM +0200, Vicent Mas wrote:
> > Hi,
> > 
> > I've just installed forrest-0.9 with the help of David Crossley (thanks again).
> > 
> > Unfortunately it can't build my website (that I built when 0.9 was the
> > developer version).
> > With 'forrest run' I get the following error:
> > 
> > Internal Server Error
> > Message: null
> > Description: No details available.
> > Sender: org.apache.cocoon.servlet.CocoonServlet
> > Source: Cocoon Servlet
> > cause
> > 
> > C:\Users\Vicente\Apache
> > Forrest\forrest\main\webapp\C:\Users\Vicente\ViTables\Website\forrest\build\tmp\C:\Users\Vicente\Apache
> > Forrest\forrest\build\plugins\dataModel.xmap (El nombre de archivo, el
> > nombre de directorio o la sintaxis de la etiqueta del volumen no son
> > correctos)
> > 
> > request-uri
> > /index.html
> > 
> > Request URI
> > index.html
> >
> > If I do a clean, run 'forrest' and read the broken-links.xml file it says:
> > 
> > <broken-links>
> >   <link message="C:\Users\Vicente\Apache
> > Forrest\forrest\main\webapp\.\C:\Users\Vicente\ViTables\Website\forrest\build\tmp\C:\Users\Vicente\Apache
> > Forrest\forrest\build\plugins\dataModel.xmap (El nombre de archivo, el
> > nombre de directorio o la sintaxis de la etiqueta del volumen no son
> > correctos)">linkmap.html</link>
> > </broken-links>
> > 
> > I don't know what to do now. Any ideas?
> 
> Those mangled Windows pathnames are certainly a problem.

This Google search: apache forrest "mangled" Windows
found some relevant past discussion. There is dev list stuff,
plus two issues:
https://issues.apache.org/jira/browse/FOR-1108
 Dispatcher, Cocoon 2.1 and Windows
https://issues.apache.org/jira/browse/FOR-1188
 locationmap or sitemap path broken on Windows, multiple paths concatenated

These sound similar to your problems.

> First thing is to ensure that a default skinned site will work.
> In a new directory, do:
>  forrest seed-sample
>  forrest
> 
> If that works, then try configuring that sample site
> to use Dispatcher. See its forrest.properties configuration file.
> Then do the 'forrest' command again.
> 
> > Should I try forrest 0.10?
> 
> Perhaps that might help.

In the FOR-1188 issue listed above, Sjur seemed to indicate
that using svn trunk (forrest-0.10-dev) did help.

It would be great to finish investigating those issues
and hopefully remove the workarounds.

-David

> I do recall some similar issues in the past.
> I do not use Windows, so it is difficult for me to help.
> Let us hope that one of the other committers that use
> Dispatcher will assist.
> 
> -David
> 
> > TIA
> > 
> > Vicent
> > 
> > PS: I'm using Windows 8.1 (and missing my Ubuntu)
> > 
> > -- 
> > Share what you know, learn what you don't.
> > 

Mime
View raw message