forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Wright (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (FOR-1231) Forrest does not deal properly with UTF-8 .xml content, even with the proper XML content-type header, and generates corrupted HTML
Date Tue, 17 Jan 2012 08:34:39 GMT

     [ https://issues.apache.org/jira/browse/FOR-1231?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karl Wright updated FOR-1231:
-----------------------------

    Description: 
We're using Forrest to generate the Apache ManifoldCF site.  We've added Japanese content.
 The content worked fine via localhost:8888, but the generated html content does not load
properly in a browser, even though the browser correctly divines that the HTML page has utf-8
encoding.  It looks like many utf-8 characters in the source XML are handled correctly but
some are corrupted.  I've also tried the fix in FORREST-668 but this does not help.  See http://incubator.apache.org/connectors
and click on the tab in Japanese to see what I mean.  The current source for the site can
be found in: https://svn.apache.org/repos/asf/incubator/lcf/trunk/site.

I checked out latest Forrest trunk and build that but there is no improvement.


  was:
We're using Forrest to generate the Apache ManifoldCF site.  We've added Japanese content.
 The content worked fine via localhost:8888, but the generated html content does not load
properly in a browser, even though the browser correctly divines that the HTML page has utf-8
encoding.  It looks like many utf-8 characters are handled correctly but some are corrupted.
 I've also tried the fix in FORREST-668 but this does not help.  See http://incubator.apache.org/connectors
and click on the tab in Japanese to see what I mean.  The current source for the site can
be found in: https://svn.apache.org/repos/asf/incubator/lcf/trunk/site.

I checked out latest Forrest trunk and build that but there is no improvement.


    
> Forrest does not deal properly with UTF-8 .xml content, even with the proper XML content-type
header, and generates corrupted HTML
> ----------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: FOR-1231
>                 URL: https://issues.apache.org/jira/browse/FOR-1231
>             Project: Forrest
>          Issue Type: Bug
>          Components: Internationalisation (i18n)
>    Affects Versions: 0.9, 0.10-dev
>            Reporter: Karl Wright
>            Priority: Critical
>
> We're using Forrest to generate the Apache ManifoldCF site.  We've added Japanese content.
 The content worked fine via localhost:8888, but the generated html content does not load
properly in a browser, even though the browser correctly divines that the HTML page has utf-8
encoding.  It looks like many utf-8 characters in the source XML are handled correctly but
some are corrupted.  I've also tried the fix in FORREST-668 but this does not help.  See http://incubator.apache.org/connectors
and click on the tab in Japanese to see what I mean.  The current source for the site can
be found in: https://svn.apache.org/repos/asf/incubator/lcf/trunk/site.
> I checked out latest Forrest trunk and build that but there is no improvement.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message