forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Wright (Commented) (JIRA)" <>
Subject [jira] [Commented] (FOR-1233) Forrest's PDF plugin configuration documentation seems to be incorrect
Date Tue, 31 Jan 2012 07:52:15 GMT


Karl Wright commented on FOR-1233:

I understand how entities work, but I don't understand what I need to do to the project xml
catalog to configure them.

As the linked document points out, "You can supply lists of symbols for your own project too.
Create a fresh site with 'forrest seed' and see the set at the src/documentation/resources/schema/symbols-project-v10.ent
file. Copy that file to your own projects at the same location. Also add the entry to your
project xml catalog as shown in the seed site at src/documentation/resources/schema/catalog.xcat
file."  We had a file at this location which did not seem to be read.  (I've now removed it
and we patch Forrest directly.)  That is what I'm talking about.  According to your doc, this
file is supposedly created when you run "forrest seed".  Now, our site was created several
Forrest versions back, but simply copying or creating a symbols-project-v10.ent file in the
above location had no effect.  It is possible that some supporting collateral elsewhere in
the site should also be modified, but I have absolutely no idea what that collateral would
be, and I can find no doc that tells me what I'd need to do.

Perhaps the solution is, "if your site was created using "forrest seed" using a forrest version
less than 0.90, you must recreate your site to get it to work".  If so, the doc should state
that clearly.

> Forrest's PDF plugin configuration documentation seems to be incorrect
> ----------------------------------------------------------------------
>                 Key: FOR-1233
>                 URL:
>             Project: Forrest
>          Issue Type: Bug
>          Components: Documentation and website
>    Affects Versions: 0.10-dev
>            Reporter: Karl Wright
> When I follow the instructions at,
they say to place a configuration file called config.xml at the location $PROJECT_HOME/src/documentation/resources/schema/symbols-project-v10.ent.
 However, when I create this file and point it to a config.xml, as stated in the documentation,
the config.xml is never parsed.  (I can determine this by making the xml badly formed, which
I would hope would cause an error of some kind).  I have not gone into using strace to see
where Forrest is actually looking but will try this soon.
> I am using the trunk version of Forrest at the moment.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message