forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benson Margulies <bimargul...@gmail.com>
Subject Re: [VOTE] please review release candidate then vote
Date Thu, 03 Feb 2011 02:48:09 GMT
Lots of people still embed antique copies of Jetty. They have this
annoying tendency to just work.

On Wed, Feb 2, 2011 at 9:44 PM, Brian M Dube <bdube@apache.org> wrote:
> On Thu, Feb 03, 2011 at 12:41:53PM +1100, David Crossley wrote:
>> Tim Williams wrote:
>> >
>> > It seems that we forgot to update our Jetty version and it's *really*
>> > old.  It's not technically a blocker and we wouldn't recommend a
>> > production deployment using our embedded Jetty anyway, but it's
>> > embarrassingly old.  I don't know what's involved in updating it but
>> > it shouldn't be that difficult.  Anyway, I could go either way on this
>> > one.
>>
>> There are various things that we should have upgraded, e.g. Ant.
>>
>> Yeah it would be great to have upgraded Jetty. I did try at various
>> stages, but cannot remember why i was not successful.
>
> Launching Jetty is done differently in current versions. Our
> configuration file would also need to be redone. I'm working on this
> now.
>
>> The old one works at the moment, good on it. If someone manages
>> to get it upgraded, and if we need a new RC for other reasons
>> then i reckon that we should include it. Otherwise IMO do a new
>> release for 0.10 soon after, to update various supporting products.
>>
>> -David
>

Mime
View raw message