forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Crossley (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FOR-1187) upgraded PDF plugin was not deployed properly
Date Mon, 10 Jan 2011 06:10:46 GMT

    [ https://issues.apache.org/jira/browse/FOR-1187?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12979483#action_12979483
] 

David Crossley commented on FOR-1187:
-------------------------------------

Using trunk r628287 prior to the new changes, built the plugin with 'ant dist' then committed
the "*-0.2.zip" directly to forrest/site/plugins/0.8/

Then tested with a Forrest-0.8 release, by specifying 0.2 pdf plugin in project forrest.properties
config. Okay.

Using trunk head, did 'deploy' and 'release' targets. This put the "*-0.3.zip" to forrest/site/plugins/0.8/
along with the unversioned copy for default.

Then tested with a Forrest-0.8 release, by removing the local plugins/org.apache.forrest.plugin.output.pdf
directory. It tried with the new plugin, but fails because it is needing other jars that are
only in forrest-0.9 lib/core etc.

So deleted the "0.3" version from the "/0.8/" area.

Incremented the "forrest version" number in its descriptor and build.xml to be "0.9" and did
deploy/release again. This put the "*-0.3.zip" to forrest/site/plugins/0.9/ along with the
unversioned copy for default.

So users of 0.8 would need to specify 0.2 version of the plugin instead of the default current
version. (Of course in this PDF case they don't need to, as per comments above.)

> upgraded PDF plugin was not deployed properly
> ---------------------------------------------
>
>                 Key: FOR-1187
>                 URL: https://issues.apache.org/jira/browse/FOR-1187
>             Project: Forrest
>          Issue Type: Bug
>          Components: Plugin: output.pdf
>    Affects Versions: 0.7, 0.8
>            Reporter: David Crossley
>            Assignee: David Crossley
>             Fix For: 0.9-dev
>
>
> Around January 2008 the PDF plugin was upgraded, gaining functionality that was only
relevant to forrest-0.9-dev. It was re-deployed without changing the version numbers in the
plugin descriptor.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message