forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Williams <william...@gmail.com>
Subject Re: unable to run forrest
Date Tue, 03 Aug 2010 12:21:49 GMT
On Tue, Aug 3, 2010 at 8:16 AM, Vicent Mas <uvemas@gmail.com> wrote:
> Hi list,
>
> after  a long time (more than one year) without working  with computers due to
> several problems I'm trying to come back to my normal activity with computers.
> One of the first things I'm trying to do is to update my dispatcher website
> (www.vitables.org) but I'm unable to do it. I've done a fresh trunk check out
> which built with no problems (just a couple of deprecation warnings):
>
> rachael:/opt/forrest_trunk/main# ./build.sh
> Using classpath:
> ../lib/endorsed/jakarta-bcel-20040329.jar:../lib/endorsed/jakarta-regexp-1.5.jar:../lib/endorsed/xalan-2.7.1.jar:../lib/endorsed/xercesImpl-2.9.1.jar:../lib/endorsed/xml-apis-1.3.04.jar
> Buildfile: build.xml
>
> init:
> Created dir: /opt/forrest_trunk/build
>
>      --------------------------------------------------------------
>
>      Using Apache Ant version 1.7.1 compiled on September 26 2008
>      Build file /opt/forrest_trunk/main/build.xml
>      Use 'build.[sh|bat] -projecthelp' to see other options.
>      Build system home /opt/forrest_trunk/tools/ant
>      Build number 0
>      Project Name Forrest build file
>      Java Version 1.6
>      Timestamp 201008031357
>      This is: apache-forrest 0.9-dev
>
>      --------------------------------------------------------------
>
>
> compile:
> Created dir: /opt/forrest_trunk/build/classes
> Compiling 33 source files to /opt/forrest_trunk/build/classes
> /opt/forrest_trunk/main/java/org/apache/forrest/log/ForrestLogTargetFactory.java:22:
> warning: [deprecation] org.apache.cocoon.util.log.CocoonTargetFactory
> in org.apache.cocoon.util.log has been deprecated
> import org.apache.cocoon.util.log.CocoonTargetFactory;
>                                 ^
> /opt/forrest_trunk/main/java/org/apache/forrest/log/ForrestLogTargetFactory.java:30:
> warning: [deprecation] org.apache.cocoon.util.log.CocoonTargetFactory
> in org.apache.cocoon.util.log has been deprecated
>    extends CocoonTargetFactory {
>            ^
> Note: Some input files use unchecked or unsafe operations.
> Note: Recompile with -Xlint:unchecked for details.
> 2 warnings
>
> jar:
> Building jar: /opt/forrest_trunk/build/xml-forrest.jar
>
>  *-----------------------------------------------------------------
>  | Installation notice
>  *-----------------------------------------------------------------
>  | You have now built the 0.9-dev version of Forrest.
>  | Please set the environment variable FORREST_HOME to point to
>  |  /opt/forrest_trunk
>  | It is recommended to add
>  |    unix: $FORREST_HOME/bin: to your $PATH
>  |    win: %FORREST_HOME%\bin; to your %PATH%
>  | Then do 'forrest -projecthelp' to list options for the 'forrest' command
>  | More help at http://forrest.apache.org/
>  *-----------------------------------------------------------------
>
>
> BUILD SUCCESSFUL
> Total time: 4 seconds
>
>
> After that I've created a sample site with $ forrest seed, copied the
> forrest.properties* files to my real site folder, and added my required
> plugins to the forrest.properties file:
>
> # project.required.plugins=org.apache.forrest.plugin.output.pdf
> project.required.plugins=org.apache.forrest.plugin.internal.dispatcher,org.apache.forrest.plugin.input.feeder,org.apache.forrest.themes.core
>
> Then I run $ forrest run. It fails. The output is lenghty but the only errors I
> see are the following:
>
> [...]
>
> fetch-plugins-descriptors:
> Copying 1 file to /home/vmas/ViTables/website/forrest/build/tmp
> Copying 1 file to /home/vmas/ViTables/website/forrest/build/tmp
> Fetching plugins descriptor: http://forrest.apache.org/plugins/plugins.xml
> Getting: http://forrest.apache.org/plugins/plugins.xml
> To: /home/vmas/ViTables/website/forrest/build/tmp/plugins-1.xml
> local file date : Tue Aug 03 08:53:46 CEST 2010
> Error getting http://forrest.apache.org/plugins/plugins.xml to
> /home/vmas/ViTables/website/forrest/build/tmp/plugins-1.xml
> Fetching plugins descriptor:
> http://forrest.apache.org/plugins/whiteboard-plugins.xml
> Getting: http://forrest.apache.org/plugins/whiteboard-plugins.xml
> To: /home/vmas/ViTables/website/forrest/build/tmp/plugins-2.xml
> local file date : Tue Aug 03 08:53:57 CEST 2010
> Error getting http://forrest.apache.org/plugins/whiteboard-plugins.xml
> to /home/vmas/ViTables/website/forrest/build/tmp/plugins-2.xml
> Plugin list loaded from http://forrest.apache.org/plugins/plugins.xml.
> Plugin list loaded from
> http://forrest.apache.org/plugins/whiteboard-plugins.xml.
>
> [...]
>
>      --------------------------------------------------------------
>      Installing plugin: org.apache.forrest.themes.core
>      --------------------------------------------------------------
>
>
> check-plugin:
> org.apache.forrest.themes.core is not available in the build dir.
> Trying to fetch it...
>
> init-props:
>
> echo-settings-condition:
>
> echo-settings:
>
> init-proxy:
>
> fetch-plugins-descriptors:
>
> fetch-plugin:
> Trying to find the description of org.apache.forrest.themes.core in
> the different descriptor files
> Using the descriptor file
> /home/vmas/ViTables/website/forrest/build/tmp/plugins-1.xml...
> Processing /home/vmas/ViTables/website/forrest/build/tmp/plugins-1.xml
> to /home/vmas/ViTables/website/forrest/build/tmp/pluginlist2fetchbuild.xml
> Loading stylesheet /opt/forrest_trunk/main/var/pluginlist2fetch.xsl
>
> findPlugin:
> Using the descriptor file
> /home/vmas/ViTables/website/forrest/build/tmp/plugins-2.xml...
> Processing /home/vmas/ViTables/website/forrest/build/tmp/plugins-2.xml
> to /home/vmas/ViTables/website/forrest/build/tmp/pluginlist2fetchbuild.xml
> Loading stylesheet /opt/forrest_trunk/main/var/pluginlist2fetch.xsl
>
> findPlugin:
>
>
> BUILD FAILED
> /opt/forrest_trunk/main/targets/plugins.xml:392: The following error
> occurred while executing this line:
> /opt/forrest_trunk/main/targets/plugins.xml:413: The following error
> occurred while executing this line:
> /opt/forrest_trunk/main/targets/plugins.xml:359: STOP GENERATION !
>    WARNING - Cannot find the plugin description
>    ============================================
>
>    Unable to find the description of org.apache.forrest.themes.core
> in the different descriptor files.
>    This plugin used by this project (declared in
> project.required.plugins variable of the forrest.properties).
>    Forrest will stop the generation now.
>    To correct this :
>      - Check the name of the plugin and correct it in case it is wrong,
>      - Add the missing descriptor file in the list in the
> forrest.plugins.descriptors variable (forrest.properties) if
> necessary...
>
> Total time: 8 seconds
>
> So although in the past I used the plugin org.apache.forrest.themes.core without
> problems it seems I cannot do the same now. Please, could somebody tell me how
> to fix the problem?

Hi Vicent,
I suspect your project is defined based on an old version of
dispatcher.  I think that plugin was merged into dispatcher itself so
try removing it from forrest.properties and giving it another go.

--tim

Mime
View raw message