forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Williams <william...@gmail.com>
Subject Re: building a sample site with dispatcher fails
Date Tue, 24 Aug 2010 11:19:05 GMT
On Tue, Aug 24, 2010 at 7:11 AM, Thorsten Scherler <scherler@gmail.com> wrote:
> On Thu, 2010-08-19 at 11:06 +0200, Vicent Mas wrote:
>> Hi all,
>>
>
> Hmm, I cannot reproduce your problem. I did
> cd $FORREST_HOME
> svn up -> At revision 988481.
> cd  main
> ./build.sh clean ;./build.sh
> cd ../whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher/
> forrest run
>
> http://localhost:8888/index.html -> Dispatcher based site.
>
> You do not have to deploy by hand (local deploy) since using the
> dispatcher plugin to test will automatically deploy the plugin.
>
> thorsten@mcKenny:~/src/apache/forrest$ find . -name *.dispatcher.jar
> ./whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher/build/org.apache.forrest.plugin.internal.dispatcher.jar
> ./build/plugins/lib/org.apache.forrest.plugin.internal.dispatcher.jar
>
> That is under ubuntu 10.04.
>
> I tried with forrest but that resulted in
> <link message="net.sf.ehcache.Element; local class incompatible: stream
> classdesc serialVersionUID = 3343087714201120157, local class
> serialVersionUID = 1098572221246444544">linkmap.html</link>

Hi Thorsten,
I wonder if you missed my note and didn't do forrest clean on an
already built site first?

http://article.gmane.org/gmane.text.xml.forrest.devel/28065/match=

If that's not it, can you provide the steps to reproduce?
Thanks,
--tim

Mime
View raw message