forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vicent Mas <uve...@gmail.com>
Subject Re: building a sample site with dispatcher fails
Date Sat, 07 Aug 2010 09:34:50 GMT
2010/8/7 David Crossley <crossley@apache.org>:
> Vicent Mas wrote:
>> Sina K. Heshmati wrote:
>> > "Vicent Mas" said:
>> >>
>> >> after coming back to the initial situation (fresh check out of the
>> >> repo) the problems
>> >> with my dispatcher seed site are obviously reproduced. When executing
>> >> "$ forrest run"
>> >> the console displays the following errors:
>> >
>> > <?snipped?>
>> >
>> >> The errors in sitemap.log are apparently the same than in error.log.
>> >> It seems that the main
>> >> problem is that the
>> >> org.apache.forrest.dispatcher.transformation.DispatcherTransformer
>> >> class
>> >> cannot be loaded. Unfortunately I have no idea about how to fix it. I
>> >> hope the above info helps
>> >> somebody.
>> >
>> > Do you run ./build.sh in $FORREST_HOME/main?
>>
>> Yes, I did. I got the same result included in the PS of the first
>> message of this thread.
>
> I reckon that Sina is on the right track.
> It seems like your installation is using an old
> version of the dispatcher plugin, or something
> is not being re-built and re-deployed correctly.
>

First of all, thanks for your answer.

> This is strange because you said that it was
> a fresh 'svn co'.
>

Yes, that is what I did. And I've just done it again (first I've renamed my
working repository, r882421)

> I know that this part is basic:
> Ensure that $FORREST_HOME is not pointing to
> an old installation, and that $PATH is correct.
> ]$ which forrest
>

$ echo FORREST_HOME
/opt/forrest

$ which forrest
/opt/forrest/bin/forrest

> Anyway, try this:
>
> ]$ cd $FORREST_HOME/main
> ]$ ./build.sh clean

vmas@rachael:/opt/forrest/main$ ./build.sh clean
Using classpath:
../lib/endorsed/jakarta-bcel-20040329.jar:../lib/endorsed/jakarta-regexp-1.5.jar:../lib/endorsed/xalan-2.7.1.jar:../lib/endorsed/xercesImpl-2.9.1.jar:../lib/endorsed/xml-apis-1.3.04.jar
Buildfile: build.xml

init:

      --------------------------------------------------------------

      Using Apache Ant version 1.7.1 compiled on September 26 2008
      Build file /opt/forrest/main/build.xml
      Use 'build.[sh|bat] -projecthelp' to see other options.
      Build system home /opt/forrest/tools/ant
      Build number 1
      Project Name Forrest build file
      Java Version 1.6
      Timestamp 201008071107
      This is: apache-forrest 0.9-dev

      --------------------------------------------------------------


clean:
Deleting directory /opt/forrest/build

BUILD SUCCESSFUL
Total time: 0 seconds

> ]$ ./build.sh
> ]$
vmas@rachael:/opt/forrest/main$ ./build.sh
Using classpath:
../lib/endorsed/jakarta-bcel-20040329.jar:../lib/endorsed/jakarta-regexp-1.5.jar:../lib/endorsed/xalan-2.7.1.jar:../lib/endorsed/xercesImpl-2.9.1.jar:../lib/endorsed/xml-apis-1.3.04.jar
Buildfile: build.xml

init:
Created dir: /opt/forrest/build

      --------------------------------------------------------------

      Using Apache Ant version 1.7.1 compiled on September 26 2008
      Build file /opt/forrest/main/build.xml
      Use 'build.[sh|bat] -projecthelp' to see other options.
      Build system home /opt/forrest/tools/ant
      Build number 0
      Project Name Forrest build file
      Java Version 1.6
      Timestamp 201008071107
      This is: apache-forrest 0.9-dev

      --------------------------------------------------------------


compile:
Created dir: /opt/forrest/build/classes
Compiling 33 source files to /opt/forrest/build/classes
/opt/forrest/main/java/org/apache/forrest/log/ForrestLogTargetFactory.java:22:
warning: [deprecation] org.apache.cocoon.util.log.CocoonTargetFactory
in org.apache.cocoon.util.log has been deprecated
import org.apache.cocoon.util.log.CocoonTargetFactory;
                                 ^
/opt/forrest/main/java/org/apache/forrest/log/ForrestLogTargetFactory.java:30:
warning: [deprecation] org.apache.cocoon.util.log.CocoonTargetFactory
in org.apache.cocoon.util.log has been deprecated
    extends CocoonTargetFactory {
            ^
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
2 warnings

jar:
Building jar: /opt/forrest/build/xml-forrest.jar

  *-----------------------------------------------------------------
  | Installation notice
  *-----------------------------------------------------------------
  | You have now built the 0.9-dev version of Forrest.
  | Please set the environment variable FORREST_HOME to point to
  |  /opt/forrest
  | It is recommended to add
  |    unix: $FORREST_HOME/bin: to your $PATH
  |    win: %FORREST_HOME%\bin; to your %PATH%
  | Then do 'forrest -projecthelp' to list options for the 'forrest' command
  | More help at http://forrest.apache.org/
  *-----------------------------------------------------------------


BUILD SUCCESSFUL
Total time: 2 seconds


> ]$ cd $FORREST_HOME/whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher
> ]$ $FORREST_HOME/tools/ant/bin/ant clean

vmas@rachael:/opt/forrest/whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher$
$FORREST_HOME/tools/ant/bin/ant clean
Buildfile: build.xml

init-build-compiler:

echo-init:
     [echo]
     [echo]       --------------------------------------------------------------
     [echo]
     [echo]       Using Apache Ant version 1.7.1 compiled on September 26 2008
     [echo]       Build file
/opt/forrest/whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher/build.xml
     [echo]       Use 'build.[sh|bat] -projecthelp' to see other options.
     [echo]       Build system home /opt/forrest/tools/ant
     [echo]       Build number 2
     [echo]       Project Name Forrest plugin build file
     [echo]       Java Version 1.6
     [echo]       Timestamp 201008071110
     [echo]
     [echo]       --------------------------------------------------------------
     [echo]

init:

clean:

BUILD SUCCESSFUL
Total time: 0 seconds

> ]$ $FORREST_HOME/tools/ant/bin/ant local-deploy
>
Buildfile: build.xml

init-build-compiler:

echo-init:
     [echo]
     [echo]       --------------------------------------------------------------
     [echo]
     [echo]       Using Apache Ant version 1.7.1 compiled on September 26 2008
     [echo]       Build file
/opt/forrest/whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher/build.xml
     [echo]       Use 'build.[sh|bat] -projecthelp' to see other options.
     [echo]       Build system home /opt/forrest/tools/ant
     [echo]       Build number 3
     [echo]       Project Name Forrest plugin build file
     [echo]       Java Version 1.6
     [echo]       Timestamp 201008071111
     [echo]
     [echo]       --------------------------------------------------------------
     [echo]

init:

compile:

jar:

local-deploy:
     [echo] Locally deploying org.apache.forrest.plugin.internal.dispatcher
     [copy] Copying 355 files to
/opt/forrest/build/plugins/org.apache.forrest.plugin.internal.dispatcher
     [copy] Copied 91 empty directories to 5 empty directories under
/opt/forrest/build/plugins/org.apache.forrest.plugin.internal.dispatcher
     [copy] Copying 1 file to /opt/forrest/build/plugins
     [copy] Copying 14 files to /opt/forrest/build/plugins/lib

build:

BUILD SUCCESSFUL
Total time: 0 seconds


> Assuming that your dispatcher has been deployed before,
> then that "clean" step should report something like:
>
> ]$ clean:
> ]$ [delete] Deleting directory $FORREST_HOME/build/plugins/org.apache.forrest.plugin.internal.dispatcher
> ]$ [delete] Deleting directory $FORREST_HOME/whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher/build/classes
>
> -David
>

As you can see no messages about deleting files appear so I assume
that older installations are not the problem.
Unfortunately when I create a seed site with dispatcher the problems
reported in the first message of this thread
appear again. The log files contents are also similar to that I sent before.

More info (I don't know if useful at all): I have removed an old
installation of ant-1.7.1 just in case. I've fop-0.95 installed
from sources. I've sun jdk1.6 installed from a debian package.

So I still need help with this problem. Your suggestions will be really welcome.

TIA

Vicent

-- 
Share what you know, learn what you don't.

Mime
View raw message