forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Williams <william...@gmail.com>
Subject Re: trouble publishing project docs
Date Mon, 31 May 2010 12:13:47 GMT
On Mon, May 31, 2010 at 1:04 AM, David Crossley <crossley@apache.org> wrote:
> Gav... wrote:
>> > >
>> > > maybe:
>> > > rm -Rf ~/.ssh/auth
>> >
>> > I suppose that you mean ~/.subversion/auth
>> >
>> > Yeah already tried that in desperation. Tried again now
>> > but same issue.
>>
>> So now you have removed the auth/svn.ssh directory, can you still
>> commit normally to trunk, using the same password you are using in
>> the deploy.svn.settings file -- if you have removed auth then you
>> will be prompted for a password from the command line.
>
> Yes, that is what i have been saying all along.
>
> Everything else is as expected, just the local forrestbot
> cannot commit using its Jsvn task.

I guess I've never investigated how forrestbot actually works, but
this jsvn library is terrible.  I can't find any documentation and all
the useful links are broken.  I was trying to find out if there was a
"--no-auth-cache" equivalent for that svncheckout task.  I wonder why
we don't just call out to external svn commands in all places (just
like svn status) since svn is a dependency anyway?

--tim

Mime
View raw message