forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sjur Moshagen <sju...@mac.com>
Subject Re: Latin1 character problems in dispatcher
Date Thu, 20 May 2010 12:18:40 GMT

Den 20. mai. 2010 kl. 14.51 skrev Thorsten Scherler:

> 
> On 20/05/2010, at 13:15, Sjur Moshagen wrote:
> 
>> Den 20. mai. 2010 kl. 13.56 skrev Thorsten Scherler:
>> 
>>> Are you using the latest head revision, because I had a similar usecase and after
the fix it works fine.
>>> 
>>> Make sure you did a clean before building again.
>> 
>> Just to double check, I did the following in $FORREST_HOME:
>> 
>> $ svn up
>> $ cd main/
>> $ ./build.sh clean
>> $ ./build.sh
>> 
>> I then switched to my project, and did:
>> 
>> $ forrest clean
>> $ forrest run -Dforrest.jvmargs="-Dfile.encoding=utf-8"
>> 
>> I also tried with regular 'forrest run'.
>> 
>> The result is still the same - Latin1 chars are not rendered.
> 
> Hmm, that is weird. Please try the following:
> - add a new contract that uses ñ, í and similar characters
> - see what comes out

I added a blank contract that just printed the same line of characters I used earlier for
testing, and this is what came out:

This is a text containing problematic characters:
a á c č d đ n ŋ s š t ŧ z ž ae æ oe ø ao å a¨ ä o¨ ö g ǥ h ħ u ʉ i ɨ

That is, the text from the contract comes through just fine, but text coming from a standard
Forrest v2 document gets garbled.

I have attached a picture of the page as it renders. The box comes from the document, the
text at the bottom is from the contract.

> further can you open a terminal and tell me what the output of "locale" are?

$ locale
LANG="no_NO.UTF-8"
LC_COLLATE="no_NO.UTF-8"
LC_CTYPE="no_NO.UTF-8"
LC_MESSAGES="no_NO.UTF-8"
LC_MONETARY="no_NO.UTF-8"
LC_NUMERIC="no_NO.UTF-8"
LC_TIME="no_NO.UTF-8"
LC_ALL="no_NO.UTF-8"

Sjur


Mime
View raw message