forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: ElemTemplateElement error: carry-body-attribs caused by r887050
Date Thu, 13 May 2010 08:50:19 GMT
Brian M Dube wrote:
> Sjur Moshagen wrote:
> > 
> > I'm not able to build my site anymore, due to the following error:
> > 
> > X [0]                                     linkmap.html	BROKEN: ElemTemplateElement
error: carry-body-attribs
> > 
> > I was finally able to track down the cause of the error being the commit r887050.
I haven't identified this earlier since I hadn't been updating my Forrest instance in a while,
and then didn't have time to track down the error earlier.
> > 
> > Tracking down ... that's kind of an overstatement, since the actual bug is not found.
The thing is, this bug does NOT display using a regular seed. I can only trigger this bug
using my own site.
> 
> How is the bug triggered?

I presume just by running 'forrest' (i.e. 'forrest site').
In default sites, "linkmap.html" is the first document to
be processed.

Remember that "linkmap" is a special pipeline.

To help isolate the problem, try setting the "start-uri"
to be something else (in forrest.properties)
e.g. project.start-uri=index.html

Don't know if that is of any help.

 ---oOo---

Sjur, you are talking about a Dispatcher-based site, correct?

Are you sure that r887050 is the cause?
Remember that the svn merge of the new Dispatcher branch
happened one day prior to that date, 03 December 2009.

-David

Mime
View raw message