forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Lehmkuehler <andr...@lehmi.de>
Subject Re: JIRA problems (Was: ForrestBot build for forrest-docs FAILED)
Date Wed, 14 Apr 2010 17:36:44 GMT
Hi,

Gav... schrieb:
> 
>> -----Original Message-----
>> From: David Crossley [mailto:crossley@apache.org]
>> Sent: Wednesday, 14 April 2010 7:43 PM
>> To: dev@forrest.apache.org
>> Subject: Re: JIRA problems (Was: ForrestBot build for forrest-docs
>> FAILED)
>>
>> On Mon, Apr 12, 2010 David Crossley wrote:
>>> ...
>>>>      [java] X [0]                                     forrest-
>> issues.html	BROKEN: /export/home/config/forrestbot-
>> trunk/conf/work/forrest-docs/. (Is a directory)
>>> ...
>>>
>>> Now that Jira is back online, we seem to be getting this problem
>>> on every run, rather than just sporadically.
>>>
>>> This is where forrest processes a report out of the JIRA
>>> issue tracker. I gather that the weird failure message is
>>> because Forrest suddenly has no content to process because
>>> the JIRA query failed to return results.
>>>
>>> Someone will need to investigate and follow up with ASF Infra.
> 
> the forrest-issues.html is produced from the forrest.properties property:
> 
> project.issues-rss-url=http://issues.apache.org/jira/secure/IssueNavigator.j
> spa?view=rss&pid=12310000&fixfor=12310041&resolutionIds=-1&sorter/field=prio
> rity&sorter/order=DESC&tempMax=25&reset=true&decorator=none
Did you try to use https instead of http? We have a similar issue with some 
attachements, which will be downloaded from JIRA from the PDFBox ant build.xml.
After changing the protocol everything works fine.

BR
Andreas Lehmkühler

Mime
View raw message