forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: trouble publishing project docs with forrestbot
Date Thu, 18 Mar 2010 01:37:12 GMT
Gav... wrote:
> From: David Crossley
> > 
> > I haven't tried since before the recent SVN access changes.
> 
> hmm, LDAP has been introduced but this shouldn't have affected svn access in
> any way.
> 
> Your old svn password is still your svn password. The main change is that
> your people.a.o changed to using LDAP.
> 
> There is the ability to sync the two (LDAP + svn) into one using
> https://svn.apache.org/change-password - you will need to use your SVN
> password to log in to this area , so is a good test to know you are using
> the correct one in your settings file.

The message to all committers in February said that we
could change it if we needed to. I already knew my shell
password (even though i always use SSH for machine logins)
so that automatically became my new SVN password.
No worries, that all worked as expected. See below.

> > Note that i have edited my $FORREST_HOME/deploy.svn.settings file.
> 
> Edited in what way? As noted your svn password should not have changed,
> unless you have synced it with LDAP already, in which case try your
> people.a.o password.

Yep, that is what my edit was. That file is used by the
local forrestbot.

> > I can commit changes to the sources.
> > 
> > Just having recent trouble with:
> > $] forrest -f publish.xml deploy
> 
> So you can commit to repos/asf/forrest/trunk via the command line but not
> repos/asf/forrest/site via forrestbot.

Correct.

> As the acl is the same for both is
> 'sounds' like at least you are using the wrong p/w in the
> deploy.svn.settings file.

Tried both of course, to no avail.

> Let me know if you continue to have trouble and we'll dig some more.

I wondered if "jsvn" (which Forrestbot uses) has cached the old
settings. However, have not had time to investigate.

-David

Mime
View raw message