forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav..." <ga...@16degrees.com.au>
Subject RE: trouble publishing project docs with forrestbot
Date Wed, 17 Mar 2010 22:29:31 GMT


> -----Original Message-----
> From: David Crossley [mailto:crossley@apache.org]
> Sent: Wednesday, 17 March 2010 4:35 PM
> To: dev@forrest.apache.org
> Subject: trouble publishing project docs with forrestbot
> 
> Would another committer try to publish the Forrest project docs:
> 
> $] cat etc/publishing_our_site.txt

Done.

> 
> I haven't tried since before the recent SVN access changes.

hmm, LDAP has been introduced but this shouldn't have affected svn access in
any way.

Your old svn password is still your svn password. The main change is that
your people.a.o
changed to using LDAP.

There is the ability to sync the two (LDAP + svn) into one using

https://svn.apache.org/change-password - you will need to use your SVN
password to log in to this area , so is a good test to know you are using
the correct one in your settings file.

> 
> Note that i have edited my $FORREST_HOME/deploy.svn.settings file.

Edited in what way? As noted your svn password should not have changed,
unless you have synced it with LDAP already, in which case try your
people.a.o password.

> 
> I can commit changes to the sources.
> 
> Just having recent trouble with:
> $] forrest -f publish.xml deploy

So you can commit to repos/asf/forrest/trunk via the command line but not
repos/asf/forrest/site via forrestbot. As the acl is the same for both is
'sounds' like at least you are using the wrong p/w in the
deploy.svn.settings file.

Let me know if you continue to have trouble and we'll dig some more.

Gav...

> 
> -David



Mime
View raw message