forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav..." <ga...@16degrees.com.au>
Subject [VOTE] - Upgrade Java Version to 1.5
Date Thu, 04 Mar 2010 00:02:09 GMT
Hi All,

This vote is to move 'trunk' to using java version 1.5.
This also means advising users/devs that this is the minimum required
version and that testing on versions of Java earlier than 1.5 will not be
supported.

Parts of the current trunk, including 'Dispatcher' do not work or do not
work well with Java 1.4.x

I have tested current trunk and dispatcher with Java 1.5 and it works well
FOR ME. Java 1.6 also works fine.

I propose that we move to Java 1.5 on trunk immediately following a
successful vote. I also propose that before voting, that devs TEST Java 1.5
on trunk and in their own current usage. Only vote for this change if you
are happy that things will continue to work or will begin to work well for
YOU.

This vote for moving to Java 1.5 is to last until at least after the next
release, so that we have at least one official release using the minimum
Java 1.5 spec.

Please take your time and vote when your ready, this vote will run for ONE
WEEK beginning now and ending on 11th March 2010 12PM (noon) GMT time.

[ ] - +1 Yes let's make the move.

[ ] - +/-0 I don't mind either way.

[ ] - -1 I strongly object and here are my reasons ...

Thanks All

Gav..



Mime
View raw message