forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav..." <ga...@16degrees.com.au>
Subject Java Version (was RE: Can't get Dispatcher working at all windows/linux from trunk)
Date Sat, 27 Feb 2010 12:08:10 GMT


> -----Original Message-----
> From: David Crossley [mailto:crossley@apache.org]
> Sent: Monday, 22 February 2010 8:11 PM
> To: dev@forrest.apache.org
> Subject: Re: Can't get Dispatcher working at all windows/linux from
> trunk
> 
<snip>
> 
> As said before, one of the issues is the agreed Java base version.
> See the "build.compiler.vm" parameter in our build.xml
> and instructions in the Release documentation and recent discussion
> in these dev archives.
> 
> -David

Seems to me, from my tests at least on linux/windows, it is the only issue
in
getting dispatcher working. All of the plugins would need checking too I
guess.

so how about we get on and vote for moving to 1.5 immediately and for the
next
release, deciding after then to perhaps move to 1.6 ? We are after all still
in
the 0.x development stages and we are more obliged to make developers lives
easier
at this stage ahead of the concerns of users even though I feel most users
would
likely have been on 1.5+ themselves for a while now. The other option is
moving 
directly to 1.6 (more correctly java 6). 

I'm happy with either, what I would not be happy about is people dallying
around 
for another few months before making a decision. This need to be sorted now
so
devs can get on with a working trunk.

Gav...





Mime
View raw message