forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cyriaque Dupoirieux <cyriaque.dupoiri...@pco-innovation.com>
Subject Re: Dispatcher problem with forrest seed
Date Thu, 24 Dec 2009 09:14:43 GMT
le 24/12/2009 06:28 Brian M Dube a écrit :
> On Tue, Dec 22, 2009 at 05:14:00PM +1100, David Crossley wrote:
>   
>> Cyriaque Dupoirieux wrote:
>>     
>>> I don't succeed to generate the basic forrest seed with the dispatcher.
>>>       
>> I just tried a fresh seed site, and no such problems here
>> (Macintosh with either java-1.5 or 1.4.2).
>>     
> I've rebuilt and I see the same issue on Linux with OpenJDK 1.6.0.
>   
You have the same configuration than I. I also have a JDK 1.6 It may be
the problem.
I set the build.compiler.vm=1.5 in my forrest.properties but the problem
remains.

>   
>> Also the forrestbot on the zone server is not reporting such problems
>> (Solaris 10 with java-1.4.2).
>>     
> That is odd. I thought I had rebuilt when I first read Cyriaque's
> report, but I'm sure that I have three times now. I'll step back in
> svn until I build cleanly again, but probably not tonight.
>
>   
I have also done this, error messages are still there.

>> Oh, have you re-built Forrest in 'main' after the merge
>> of the Dispatcher branch recently? See mail here around
>> December 2 to December 5.
>>
>> -David
>>     
> This last bit doesn't belong in this thread, but I noticed it while
> looking into this issue and I'm being lazy. The icon-b.png
> error. Maybe not everyone experiences it, but I believe it has been
> brought up before. While looking at the issue of this thread, I
> noticed build/images/icon-b.png, while the rest of the build is under
> build/site. Surely that's the cause of the NullPointer(FileNotFound)
> exception that Java throws, but there's a larger problem involved. We
> cannot, must not, may not *write* in the filesystem outside the
> expected target. I think this issue has been raised in the past.
> I'll try to look into it; this is merely the lazy documentation
> of what I've found.
>   
This is weird, the /site/samples-b/linking.html page shows the
icon-b.png in the example 5 (generated without the dispatcher)
I think we should change the name of every images used in these examples
(like 1, 2, 3 and so on.) to be able to find more quickly the problem.
In the list, 3 examples use the icon-a.png...

I think this error is old,


Happy Christmas, and read you next year...


Salutations,
Cyriaque
> Brian
>   


Mime
View raw message