forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Java version of plugins/main (was Re: strange Dispatcher behaviour after merge)
Date Mon, 07 Dec 2009 01:40:46 GMT

On 05/12/2009, at 01:25, David Crossley wrote:

> Dispatcher seems to have some strange behaviours after the recent merge.
> I don't have much time, so here is a quick dump of notes.
> Perhaps someone else can raise Jira issues for them.
> 
> Using Java-1.5
> 
> 1) Rebuild forrest. All seems okay.
> 2) cd $FORREST_HOME/whiteboard/plugins/org.apache.forrest.plugin.internal.dispatcher
> 3) rm -rf build
> 3) $FORREST_HOME/tools/ant/bin/ant local-deploy
> 4) Get compilation errors and "BUILD FAILED" (see [A])
> 
> It sounds like someone needs to get the PMC to agree on
> increasing the base Java version.

You are right that a version change needs a PMC vote. When I did the rewrite of the dispatcher
I was using 1.5 and 1.6 since I do not use 1.4 since a long time. 

Regarding the support of 1.4, the EOSL transition period began Dec, 11 2006 and completed
October 30th, 2008, meaning 1.4 is only supported for Solaris user.
Regarding the support for 1.5 it reached its End of Service Life (EOSL) on November the 3rd
2009.

Like said dispatcher is ATM 1.5 due to use of generics and a couple of other things (annotations).
It should not be hard to fix this, if we decide to keep our support for 1.4.

However in the light of above (1.4 and 1.5 reached their EOSL) I think we should raise the
minimum version of forrest to at least 1.5 if not 1.6.

salu2


Mime
View raw message