forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vicent Mas <uve...@gmail.com>
Subject problem with site.xml and tabs.xml: empty menus
Date Fri, 27 Mar 2009 07:54:06 GMT
Hi,

I'm a newbie. I recently intalled forrest-0.90 from svn and started playing
with it. First I tried the skin approach. After some reading, I decided that
using dispatcher was the way to go so I did. Now I've some problems that
I don't know how to fix.

The first problem is related with site.xml and tabs.xml. When a tab has no
visible content if I click on that tab then it is expanded showing an empty
menu. However the expected behavior should be just  select the tab and do not
expand it, simply display the file referenced in the indexfile attribute. This
is in fact what happens using the skin approach.

My site.xml and tabs.xml are:

<tabs software="The Forresters"
			title="The Forresters"
			copyright="The Apache Software Foundation"
			xmlns:xlink="http://www.w3.org/1999/xlink">
  <tab id="home" label="Home" dir="" indexfile="index.html"/>
  <tab id="screenshots" label="Screenshots" dir="screenshots"
indexfile="screenshots.html"/>
	<tab id="download" label="Download" dir="download" indexfile="download.html"/>
	<tab id="development" label="Development" dir="development"
indexfile="development.html"/>
	<tab id="reading" label="Documentation" dir="reading"
indexfile="documentation.html"/>
</tabs>


<site label="The Forresters" href=""
xmlns="http://apache.org/forrest/linkmap/1.0" tab=""
			xmlns:xi="http://www.w3.org/2001/XInclude">
	
	<overview tab="home">
		<index href="index.html" description="Overview of the project"/>
	</overview>

	<screenshots tab="screenshots" href="screenshots/">
		<index href="screenshots.html" description="Videos and Screenshots"/>
	</screenshots>

	<development tab="development" href="development/">
		<index  href="development.html" description="Project development"/>
	</development>
	
	<download tab="download" label="Getting ViTables" href="download/"
description="How to get software packages">
		<from_project label="From here" href="download.html"/>
		<distros label="From other sources" href="distros/distros.html"/>
	</download>

	<reading tab="reading" label="Docs" href="reading/"
description="Documentation about the project">
		<index label="Index" href="documentation.html"/>
		<testimonials label="Testimonials" href="testimonials/testimonials.html"/>
		<faq label="FAQ" href="faq/faq.html"/>
	</reading>
	
...
</site>
	
With the above layout, clicking on the tabs labeled as Home, Screenshots and
Development the tab is expanded showing an empty menu.

Am I doing something wrong? Is it a bug? The different behavior of the skin and
the dispatcher approaches make me think that there is a bug somewhere.

Any help will be appreciated.


Vicent

PS: if in the site.xml I replace the entries

	<overview tab="home">
		<index href="index.html" description="Overview of the project"/>
	</overview>

	<screenshots tab="screenshots" href="screenshots/">
		<index href="screenshots.html" description="Videos and Screenshots"/>
	</screenshots>

	<development tab="development" href="development/">
		<index  href="development.html" description="Project development"/>
	</development>

with

	<overview href="index.html" description="Overview of the project"/>
	<screenshots "screenshots/screenshots.html" description="Videos and
Screenshots"/>
	<development href="development/development.html" description="Project
development"/>

then clicking on those tabs show a menu that contains the menus of
both Documentation
and Download tabs
.
-- 
Share what you know, learn what you don't.

Mime
View raw message