forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: [jira] Created: (FOR-1153) Dispatcher test site page fails HTML Validation
Date Wed, 14 Jan 2009 04:33:03 GMT
Gavin wrote:
> > 
> > Line 662, Column 44: there is no attribute "target".
> > <a class="fork" href="../index.html" target="_blank">&lt;a class="fork"
> 
> How do we propose fixing this 2nd issue?
> 
> The problem we have is that we are validating the same document based on our
> document-v20 against two different DTDs, HTML 4.01 Transitional where the
> above is valid, and XHTML 1.0 Strict where it is not valid.
> 
> This sample document that we are testing is supposed to be an example of all
> our elements in use. By using <a class="fork" .../> we are adding
> target="_blank" to the generated output which is not valid.
> 
> So, do we remove this example, do we instead make it a non live link as a
> workaround so the validator does not process it, do we need to remove the
> use of 'fork' altogether so that we don't use 'target' ?

I suggest just showing the text of how to do it,
i.e. not an actual link.

It is non-standard behaviour, but it was used in previous
versions of our DTDs, so we still need to explain how to deal
with it.

Also please remember that there are various copies of
this document: at least in the seed-sample and in site-author,
and perhaps elsewhere now.

We need to minimise their differences and keep them synchronised.

-David

Mime
View raw message