forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ross Gardler (JIRA)" <j...@apache.org>
Subject [jira] Updated: (FOR-1133) PDF don't display images in deployed WAR file on Tomcat
Date Thu, 04 Dec 2008 01:09:44 GMT

     [ https://issues.apache.org/jira/browse/FOR-1133?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ross Gardler updated FOR-1133:
------------------------------

    Priority: Major  (was: Critical)
     Urgency: Normal  (was: Urgent)

This is an issue with a version of Forrest that has been in production for quite some time.
The problem would therefore appear to be with the specific configuration.

Can you please report what happens when you do forrest run and retrieve a PDF, can you also
tell us what the fo:external-graphic is when doing forrest run.

Testing a built war file in a diferent servlet engine (e.g. Jettry) would also be informative.

Please also test using 0.9-dev so that we can ascertain if this is a problem with 0.8 only
or also a problem with SVN head.

On my configuration I am unabe to reproduce this problem, so the more information you can
provide us the more likely we are to be able to help you fix the problem.

I'm reducing the priority to major as this issue needs to be confirmed as a problem in Forrest
rather than a problem in your configuration (although I note you have tested on multiple operating
systems). I'm also reducing the urgency to Normal, this means active devs are likely to help
you solve the problem, but that they are not likely to do the work for you (i.e. an existing
dev is not being affected by the issue)

> PDF don't display images in deployed WAR file on Tomcat
> -------------------------------------------------------
>
>                 Key: FOR-1133
>                 URL: https://issues.apache.org/jira/browse/FOR-1133
>             Project: Forrest
>          Issue Type: Bug
>          Components: Plugin: output.pdf
>    Affects Versions: 0.8
>            Reporter: Antoine ROBERT
>
> Hi,
> In order to make this discussion as an official issue (http://www.nabble.com/PDF-not-working-correctly-in-deployed-WAR-file-on-Tomcat-td15295911.html)
i post a JIRA.
> Bug information :
> Tools : apache-tomcat-6.0.18 + apache-forrest-0.8 + java-1.6
> OS : Windows XP and CentOs (a RedHat)
> Step to reproduce
> 1/ Download apache-forrest-0.8 (Actual release)
> 2/ Downlaod apache-tomcat-6-0.18 (Actual release)
> 3/ Use java 1.6 (Actual release)
> 4/ forrest seed (To create sample forrest site)
> 5/ forrest war (to create WAR sample forrest site)
> 6/ put the .war in the tomcat webapps folder
> 7/ Launch sample forrest application from tomcat
> 8/ Go to any page with any image of this war sample forrest site
> 9/ Try to see it in PDF version
> 10/ See that you don't have image displayed 
> The issue is that, images are not displayed .. Any image (gif, png, jpg). This issue
is only in case of a deployed WAR, that works fine in jetty.
> Here are some clues about the issue :
> When i take a look in the graphical section of the .fo file I can see that : 
> fo:external-graphic src="context:///project/src/documentation/content/xdocs/mySpecificProject/conception/specificModule/fonctionnal/../resource/anImage.jpg"

> And when I take a look in my WEB-INF/logs/core.log i can see that : 
>  http-8080-1/ExternalGraphic: Error while creating area : Error with image URL: context:/project/src/documentation/content/xdocs/mySpecificProject/conception/specificModule/fonctionnal/../resource/anImage.jpg
(No such file or directory) and no base URL is specified 
> I think that is a serious issue, and I would like your opinion about it.
> Thanks

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message