forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine ROBERT (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FOR-1133) PDF don't display images in deployed WAR file on Tomcat
Date Fri, 05 Dec 2008 19:24:46 GMT

    [ https://issues.apache.org/jira/browse/FOR-1133?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12653904#action_12653904
] 

Antoine ROBERT commented on FOR-1133:
-------------------------------------

I just updated my tests here: 

https://issues.apache.org/jira/browse/FOR-1074

And I made forrest work into tomcat 6 (By changing code into webapp.xml ant file) 

And Yes images are well displayed in PDF with this version !

Thanks and good night :) People are waiting for me to drink beer ! 

> PDF don't display images in deployed WAR file on Tomcat
> -------------------------------------------------------
>
>                 Key: FOR-1133
>                 URL: https://issues.apache.org/jira/browse/FOR-1133
>             Project: Forrest
>          Issue Type: Bug
>          Components: Plugin: output.pdf
>    Affects Versions: 0.8
>            Reporter: Antoine ROBERT
>
> Hi,
> In order to make this discussion as an official issue (http://www.nabble.com/PDF-not-working-correctly-in-deployed-WAR-file-on-Tomcat-td15295911.html)
i post a JIRA.
> Bug information :
> Tools : apache-tomcat-6.0.18 + apache-forrest-0.8 + java-1.6
> OS : Windows XP and CentOs (a RedHat)
> Step to reproduce
> 1/ Download apache-forrest-0.8 (Actual release)
> 2/ Downlaod apache-tomcat-6-0.18 (Actual release)
> 3/ Use java 1.6 (Actual release)
> 4/ forrest seed (To create sample forrest site)
> 5/ forrest war (to create WAR sample forrest site)
> 6/ put the .war in the tomcat webapps folder
> 7/ Launch sample forrest application from tomcat
> 8/ Go to any page with any image of this war sample forrest site
> 9/ Try to see it in PDF version
> 10/ See that you don't have image displayed 
> The issue is that, images are not displayed .. Any image (gif, png, jpg). This issue
is only in case of a deployed WAR, that works fine in jetty.
> Here are some clues about the issue :
> When i take a look in the graphical section of the .fo file I can see that : 
> fo:external-graphic src="context:///project/src/documentation/content/xdocs/mySpecificProject/conception/specificModule/fonctionnal/../resource/anImage.jpg"

> And when I take a look in my WEB-INF/logs/core.log i can see that : 
>  http-8080-1/ExternalGraphic: Error while creating area : Error with image URL: context:/project/src/documentation/content/xdocs/mySpecificProject/conception/specificModule/fonctionnal/../resource/anImage.jpg
(No such file or directory) and no base URL is specified 
> I think that is a serious issue, and I would like your opinion about it.
> Thanks

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message