forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin" <ga...@16degrees.com.au>
Subject RE: [heads up] our packaged Apache Ant is upgraded to v1.7.1
Date Sat, 18 Oct 2008 02:01:40 GMT


> -----Original Message-----
> From: David Crossley [mailto:crossley@apache.org]
> Sent: Wednesday, 1 October 2008 4:55 PM
> To: dev@forrest.apache.org
> Subject: [heads up] our packaged Apache Ant is upgraded to v1.7.1
> 
> Over the last few days i have upgraded our packaged
> Apache Ant at $FORREST_HOME/tools/ant to be Ant-1.7.1
> See r700693.
> 
> Our Ant was 1.6.5 which was released on 02-Jun-2005.
> 1.7.0 was released 19-Dec-2006
> 1.7.1 was released 27-Jun-2008
> 
> Also upgraded some of Ant's supporting libraries
> in tools/ant/lib.
> 
> Not yet done "xml-commons-resolver" because we still
> have FOR-889 on Windows, which we cannot encourage a
> Windows developer to help.

I'll try to soon.

> 
> Not yet done "ant-contrib" because i encountered a problem.
> Will look at that next.
> 
> It took a lot of testing and debugging. Our problems,
> not Ant's.
> 
> The main issue was in our "validate-xdocs" task,
> which broke with out-of-memory issues. After some
> time i found it was a strange bug with a previous
> commit that did not show up until this Ant upgrade.
> It is something to do with classpath - see r700348.
> Anyway, it works now but needs more investigation.
> 
> As usual the tools/ant/bin/* scripts needed our changes
> applied. This is mainly to force forrest to use our Ant,
> rather than any old system-wide Ant.
> 
> Windows users beware. The Ant developers have tried
> hard to have a start script that works on various
> Windows flavours. Then i added our minor changes,
> and i have not Windows to test with.
> 
> So if you use plain Windows, rather than via Cygwin,
> then things might not work.

I just downloaded forrest-trunk, set up a new seed-sample (skin based as my
first test) and 'forrest run' and 'forrest' work just fine, so I guess it is
working.

The only error that came from running 'forrest' was :-

ERROR - Image not found: cocoon:/images/icon-b.png

ERROR - Image not found: cocoon:/images/icon-b.png

java.lang.NullPointerException

etc.. but I believe unix-like has been seeing that also, not sure if that is
still happening for you ?

Off to alter my seed-sample into a dispatcher site and test.

Gav...

> 
> -David
> 
> 
> --
> Internal Virus Database is out-of-date.
> Checked by AVG.
> Version: 7.5.524 / Virus Database: 270.6.21 - Release Date: 9/11/2008
> 12:00 AM


Mime
View raw message