forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Crossley (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FOR-955) upgrade our packaged Cocoon to use Cocoon-2.1 branch
Date Fri, 12 Sep 2008 01:53:44 GMT

    [ https://issues.apache.org/jira/browse/FOR-955?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12630457#action_12630457
] 

David Crossley commented on FOR-955:
------------------------------------

There was a subsequent update to rebuild the cocoon jars to be Java 1.4 minimum. So r693831
is the last stable version.

The head of SVN trunk is now reported to be working on UNIX-like systems, so this FOR-955
remains closed.

However there are some issues on Windows and cygwin. These are being addressed separately
on the dev list now.

> upgrade our packaged Cocoon to use Cocoon-2.1 branch
> ----------------------------------------------------
>
>                 Key: FOR-955
>                 URL: https://issues.apache.org/jira/browse/FOR-955
>             Project: Forrest
>          Issue Type: Task
>          Components: Core operations
>    Affects Versions: 0.9-dev
>            Reporter: David Crossley
>             Fix For: 0.9-dev
>
>         Attachments: 955.diff
>
>
> These are the steps to get Forrest running with Cocoon-2.1 rather than the current situation
which uses an old Cocoon trunk. Not everything yet works, but enough to give hope. See discussion
at:
>  Re: upgrade strategies for our packaged Cocoon
>  http://marc.theaimsgroup.com/?l=forrest-dev&m=116969420304386
> --------------------------
> Steps:
> Revert main/java/org/apache/forrest/util/XPathTransformer.java r111200
> Revert main/java/org/apache/forrest/util/IdGeneratorTransformer.java r111200
> Edit main/webapp/WEB-INF/cocoon.xconf
> to change version attribute to ... cocoon version="2.1"
> Move content of WEB-INF/xconf/forrest-core.xconf into WEB-INF/cocoon.xconf
> Remove the <components> wrapper.
> Build cocoon-branch-2_1_X for the blocks that we use (see our etc/cocoon_upgrade) and
replace the jars in lib/core

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message