forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Crossley (JIRA)" <j...@apache.org>
Subject [jira] Updated: (FOR-1105) Unexpected behaviour of locationmap and themes
Date Fri, 12 Sep 2008 13:15:44 GMT

     [ https://issues.apache.org/jira/browse/FOR-1105?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Crossley updated FOR-1105:
--------------------------------

    Other Info: [Patch available]

> Unexpected behaviour of locationmap and themes
> ----------------------------------------------
>
>                 Key: FOR-1105
>                 URL: https://issues.apache.org/jira/browse/FOR-1105
>             Project: Forrest
>          Issue Type: Bug
>          Components: Locationmap
>            Reporter: Pablo Barrera
>            Priority: Minor
>         Attachments: 0002-Fix-properties-resources-themes-location.patch
>
>
> I have modified my locationmap as follows:
> 	<match pattern="themer.project.dir">
> 		<location src="{properties:home}/themes" />
> 	</match>
> I am using the pelt theme:
>   <property name="dispatcher.theme" value="pelt"/>
>   <property name="dispatcher.theme-ext" value=".fv"/>
> so I copy my themes files to its expected location:
> themes/pelt/panels/pelt-html.content.panel.xml
> themes/pelt.fv
> The pelt-html.content.panel.xml is not used but pelt.fv is.
> When looking at
> http://localhost:8888/resolve.structurer.index
> I can see my local copy but the locationmap is looking for pelt/panels/pelt-html.content.panel.xml
in the default dir, not in my local dir.
> According to the locationmap logs:
> $ cat locationmap.log | grep pelt-html.content.panel.xml | grep MY_PROPERTIES_HOME/themes
> Nothing...
> $ cat locationmap.log | grep pelt-html.content.panel.xml | grep MY_PROPERTIES_HOME
> DEBUG   [core.modules.mapper.lm] (/index.html): Not selected: PATH_TO_MY_PROPERTIES_HOME/src/documentation/resources//themes/pelt/panels/pelt-html.content.panel.xml
> DEBUG   [core.modules.mapper.lm] (/index.html): Not selected: PATH_TO_MY_PROPERTIES_HOME/src/documentation/resources//themes/common/panels/pelt-html.content.panel.xml
> DEBUG   [core.modules.mapper.lm] (/index.html): Not selected: PATH_TO_MY_PROPERTIES_HOME/src/documentation/resources//themes/pelt/panels/pelt-html.content.panel.xml
> DEBUG   [core.modules.mapper.lm] (/index.html): Not selected: PATH_TO_MY_PROPERTIES_HOME/wiki2tei/src/documentation/resources//themes/common/panels/pelt-html.content.panel.xml
> If I copy the themes/pelt/panels/pelt-html.content.panel.xml file to PATH_TO_MY_PROPERTIES_HOME/src/documentation/resources//themes/pelt/panels
the system worked correctly.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message