forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin" <ga...@16degrees.com.au>
Subject RE: ForrestBot deploy.scp working anyone ?
Date Wed, 10 Sep 2008 09:57:44 GMT


> -----Original Message-----
> From: David Crossley [mailto:crossley@apache.org]
> Sent: Wednesday, 10 September 2008 7:43 PM
> To: dev@forrest.apache.org
> Subject: Re: ForrestBot deploy.scp working anyone ?
> 
> David Crossley wrote:
> > Gavin wrote:
> > >
> > > I configured a publish.xml and settings file for SCP.
> > >
> > > I got it to the stage where it works, but it only
> > > deploys PDF files, all other files , .html .css etc are ignored!
> 
> I wonder if you are seeing the new bug
> with the pdf plugin, whereby every document
> is changed every time that you build.
> This is due to a datestamp being added
> to the generated pdf, hence always changed
> and so always deployed.

Possibly, don't know how to explain that it doesn't see all the other
file types as having been changed. This is a first deploy.

I changed the settings in forrestbots deploy.xml file to read

    <scp todir="${deploy.scp.dest}" password="${deploy.scp.password}"
trust="true">
      <fileset dir="${build.site-dir}">
              <!--<modified/>-->
              <include name="**/*.*"/>
      </fileset>

and it now works fine.

So, definitely something to do with modified times - and combined with
lack of datestamps on Windows files may have an effect also.

So, need to work out a better way, shouldn't really have to mess with
forrestbots files at all I guess.

Gav...

> 
> -David
> 
> 
> --
> No virus found in this incoming message.
> Checked by AVG.
> Version: 7.5.524 / Virus Database: 270.6.17 - Release Date: 9/5/2008 12:00
> AM


Mime
View raw message