forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: [VOTE] use Cocoon-2.1
Date Thu, 28 Aug 2008 09:59:55 GMT
Tim Williams wrote:
> David Crossley wrote:
> > We intend to "update" the version of Cocoon used by Forrest
> > to be Cocoon-2.1 branch.
> >
> > Please vote.
> 
> I reckon I've missed discussion on why 2.1.x vs the released 2.2?
> It's not intuitive why we would "upgrade" to an outdated version.  I
> saw FOR-1016 but I didn't see what the show-stopper was.  A search
> turned up this[1] thread with Thorsten concerned about "pass-through"
> - but I'm not sure what that means.

That is the ability that lets our sitemaps work.
If a match is not found then it passes through to the
next sitemap. That ability was in our old Cocoon-2.2 trunk,
and we were not sure it was backported to Cocoon-2.1 branch.
It was and it works for us.

As for the background, please see the recent "Proposal" thread.
It directs you to
http://issues.apache.org/jira/browse/FOR-1017
and to the old discussion:
http://marc.info/?t=116969435600001

-David

> I reckon I'm +0 on doing this simple to be out of our current
> predicament but think because of how non-intuitive it is, it'd be
> worth clearly stating why we are not going with the more obvious
> upgrade path.
> 
> --tim
> 
> [1] - http://www.nabble.com/memory-leaks-in-forrest-td18743789.html

Mime
View raw message