forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferdinand Soethe <>
Subject Re: Addressing FOR-652 CSS cleanup (was Re: [jira] Subscription: FOR-open-with-patch)
Date Wed, 23 Apr 2008 07:58:23 GMT

Am 22.04.2008 um 11:32 schrieb Thorsten Scherler:

> <div id="leftbar">
>  <div id="nav-section">
>   <ul>
>    <li id="menu_selected_1.1Title" class="pagegroupselected">
>    <span/>
>     <ul id="menu_selected_1.1" class="selectedmenuitemgroup">
>       <li class="menupage">
>        <div class="menupagetitle"/> <!-- Current page; no link -->
>       </li>
>       <li class="menuitem">
>         <a/>
>       </li>
>     </ul> <!--/menu_selected_1.1-->
>    </li> <!--/menu_selected_1.1Title-->
>    <li id="menu_1.2Title" class="pagegroup">
> ...
> This is way too verbose and should go away in a new version. IMO the  
> @id
> does not provide any valuable information therefore it should be
> striped. If the @id is needed for the expanding js menu is needed then
> the menu should be rewritten.
I agree. Keep in mind that bigger sites will have a lot of these  
entries within each and every page.
Having really long names will significantly increase page size.

> The id="leftbar" should be renamed to something more general.

Hmmm. I think this really depends. If this div is the container for  
the box on the left side of the page, the name is
correct and clear. If is was the container for the menu it should be  
changed. But since the menu is contained in
nav-section. Why change?

Ferdinand Soethe

View raw message