forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremias Maerki-2 <...@jeremias-maerki.ch>
Subject Re: Plans for integrating FOP .94
Date Wed, 12 Dec 2007 09:39:51 GMT

Cocoon 2.1.x doesn't have a FOP Block which works with FOP 0.94, yet. But it
would be very easy for me to write one.

So if Forrest could/would switch back to 2.1.x, that would be easy on the
FOP Block side. I don't know how much effort it would result in and if
Ferdinand could do it. I couldn't in due time, because I know too little
overall about Cocoon and Forrest to help there.

The same is true for upgrading Cocoon to the latest 2.2-RC2. The upgrading
instructions look rather complicated and I suspect I cannot allocate enough
time to really support Ferdinand here in the very short term. It probably
makes sense to upgrade to 2.2-RC2 since it's not a step back and could help
the Cocooners with feedback.


David Crossley wrote:
> 
> Thorsten Scherler wrote:
>> Ferdinand Soethe wrote:
>> > Thorsten Scherler wrote:
>> > 
>> > Thanks Thorsten. That helped quite a bit.
>> > 
>> > > Did you try to "just" add commons logging as well (drop the lib)?
> 
> Unfortunately, that won't work, since there are lower-level changes in
> Cocoon, that make the Block implementations incompatible
> (AbstractLogEnabled changed from Avalon logging to Commons Logging).
> 
>> > 
>> > I'd try if I knew where to find that lib :-)
>> 
>> http://commons.apache.org/logging/
>> 
>> > > ..or (better) update our cocoon version to the current cocoon one or
>> > > switch to cocoon-2.1.x. Otherwise we are really starting to fork
>> cocoon.
>> > 
>> > That makes sense in context of what you write below.
>> > So should I do that? And how do I get started.
>> 
>> I would try 2.1.x. 
>> First by using our files
>> http://svn.apache.org/viewvc/forrest/trunk/etc/cocoon_upgrade/
>> to build the jars that we need and then replace the ones we have in 
>> http://svn.apache.org/viewvc/forrest/trunk/lib/core/
>> 
>> After this a clean build of forrest and see what errors are thrown.
> 
> Those notes relate to our use of old Cocoon-2.2 trunk.
> I think what Thorsten might be suggesting is to use
> those notes for a guide to building Cocoon-2.1 branch instead.
> The two had a similar Ant-based build system at the time.
> 
> See our issue
> http://issues.apache.org/jira/browse/FOR-1017
>  "decide on upgrade strategy for Forrest's use of Cocoon"
> 
> Option 2 is the Cocoon-2.1 branch option and refers to FOR-955 notes.
> 
> However, i am not sure what version of FOP is being used
> in Cocoon-2.1 branch.
> 
> -David
> 
> 

-- 
View this message in context: http://www.nabble.com/Plans-for-integrating-FOP-.94-tp14112824p14291818.html
Sent from the Apache Forrest - Dev mailing list archive at Nabble.com.


Mime
View raw message