forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thorsten.scherler....@juntadeandalucia.es>
Subject RE: faq-to-document.xsl
Date Thu, 23 Aug 2007 06:13:12 GMT
On Thu, 2007-08-23 at 07:53 +0800, Gav.... wrote:
> In addition, your 1.2 docs faq shows a ToC, just your 2.0 does not.
> 
> http://lenya.apache.org/docs/1_2_x/how-to/faq.html


https://svn.apache.org/repos/asf/lenya/docu/src/documentation/content/xdocs/docs/1_2_x/how-to/faq.xml

<!DOCTYPE document PUBLIC "-//APACHE//DTD Documentation V2.0//EN"
"http://forrest.apache.org/dtd/document-v20.dtd">

This document is called faq but is an xdocs. 

...but this perfectly demonstrate the problem. 

Why would I want to have a surrounding section called Questions like we
have in the forrest one? It should be like above link.

salu2

> 
> 
> Gav...
> 
> > -----Original Message-----
> > From: Gav.... [mailto:brightoncomputers@brightontown.com.au]
> > Sent: Thursday, 23 August 2007 7:50 AM
> > To: dev@forrest.apache.org
> > Subject: RE: faq-to-document.xsl
> > 
> > Hi Thorsten,
> > 
> > Needs more investigation I think.
> > 
> > Our FAQ [1] has a ToC and works just fine.
> > 
> > Gav...
> > 
> > [1] - http://forrest.apache.org/docs_0_90/faq.html
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: Thorsten Scherler
> > [mailto:thorsten.scherler.ext@juntadeandalucia.es]
> > > Sent: Wednesday, 22 August 2007 9:15 PM
> > > To: dev@forrest.apache.org
> > > Subject: faq-to-document.xsl
> > >
> > > Hi all,
> > >
> > > the http://issues.apache.org/bugzilla/show_bug.cgi?id=42350 is caused by
> > > the faq-to-document.xsl:
> > > ...
> > > <body>
> > >         <section>
> > >           <title>Questions</title>
> > >           <xsl:apply-templates select="faq|part"/>
> > >         </section>
> > >       </body>
> > > ...
> > >
> > > This causes only one level 1 section:
> > > <tocitems>
> > > <tocitem level="1" href="#Questions" title="Questions">
> > > <tocitem level="2" href="#getting_started" title="1. Getting Started and
> > > Building Lenya">
> > > ...
> > >
> > > But if one configures the skinconf toc @min-sections to 2 then it
> > results
> > > in the above bug.
> > >
> > > I would like to patch it the following way:
> > > -        <section>
> > > -          <title>Questions</title>
> > > -          <xsl:apply-templates select="faq|part"/>
> > > -        </section>
> > > +        <xsl:apply-templates select="faq|part"/>
> > >
> > > Did I miss something or can I go ahead and change the code?
> > >
> > > salu2
> > > --
> > > Thorsten Scherler                                 thorsten.at.apache.org
> > > Open Source Java                      consulting, training and solutions
> > >
> > >
> > > --
> > > Internal Virus Database is out-of-date.
> > > Checked by AVG Free Edition.
> > > Version: 7.5.476 / Virus Database: 269.11.2/933 - Release Date: 8/2/2007
> > > 2:22 PM
> > 
> > 
> > --
> > Internal Virus Database is out-of-date.
> > Checked by AVG Free Edition.
> > Version: 7.5.476 / Virus Database: 269.11.2/933 - Release Date: 8/2/2007
> > 2:22 PM
> 
-- 
Thorsten Scherler                                 thorsten.at.apache.org
Open Source Java                      consulting, training and solutions


Mime
View raw message