forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Problems activating sitemap-debugging in .7
Date Wed, 02 May 2007 01:37:03 GMT
Ferdinand Soethe wrote:
> I need to debug some site maps in a .7 installation so I tried to
> activate the SimpleSitemapExecutor for .7 like David did for .8.
> 
> - Looked for and found the class in
>   cocoon-profiler-block-2.2.0-dev-r125082.jar
>   in lib/core
> 
> - added
>   <component role="org.apache.cocoon.sitemap.SitemapExecutor"
>       class="org.apache.cocoon.profiler.debugging.SimpleSitemapExecutor"
>         logger="debug"/>
>   to forrest-core.xconf
> 
> - checked that I have an entry for debug in logkit.
> 
> However when I run Forrest I get this message in error.log.
> 
> org.apache.avalon.framework.configuration.ConfigurationException: Cannot
> find class org.apache.cocoon.profiler.debugging.SimpleSitemapExecutor
> for component at
> file:/C:/forrest/0.7x/main/webapp/WEB-INF/xconf/forrest-core.xconf:730:25
> 
> What else is required to use/find/load this component? Or is there
> something else wrong?

I reviewed the commits for 0.8 and what you
have done for 0.7 seems to be okay.
Doing 'svn praise forrest-core.xconf' shows r365510
which only declares that component.

I wonder (not tried) if you also need the previous
stuff which enabled the profiler itself. e.g. the entry
immediately above it declares the profiler.roles
Doing 'svn praise' shows r264705 and FOR-572.
Not sure if i added everything in that one commit.

-David

Mime
View raw message