forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Blaschke <>
Subject Re: javac version (Was: [apache-forrest-0.8] problem with org.apache.forrest.plugin.output.inputModule)
Date Thu, 26 Apr 2007 10:29:19 GMT
David Crossley wrote:
> Ron Blaschke wrote:
>> Thorsten Scherler wrote:
>>> Ron Blaschke wrote:
>>>> I think this is a problem with the plugin.  If you look at the
>>>> 0.8/ there's a file
>>>> lib/org.apache.forrest.plugin.output.inputModule.jar.  It contains the
>>>> ModuleGenerator class.  This class has version 49.0, which is Java 5.
>>>> My pod-input plugins seems to have the same problem.
>>>> After a quick look into plugins/build.xml I think the javac task call
>>>> should contain target="1.4" to tell the compiler to always generate Java
>>>> 1.4 code.  Otherwise the compiler targets the default version, which is
>>>> the own version for recent Sun JDKs.
>>> Hmm, I think I used 1.5 to compile the inputModule plugin and Ron is
>>> right. Ron can you, please, attach a patch to our issue tracker for the
>>> build.xml? TIA.
>> Will do.
> A committer needed to deploy the plugin again anyway,
> so i just made the fix.

Sorry for bringing this up this late, but I guess "source" should also
be added.  It tells the compiler which Java source code version to
expect.  Could you add this?

+source=        "${build.compiler.vm}"
target=        "${build.compiler.vm}"


View raw message