forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Blaschke <...@rblasch.org>
Subject Re: [apache-forrest-0.8] problem with org.apache.forrest.plugin.output.inputModule
Date Wed, 25 Apr 2007 16:53:36 GMT
Thorsten Scherler wrote:
> On Sun, 2007-04-22 at 16:07 +0200, Ron Blaschke wrote:
>> Ross Gardler wrote:
>>> On 20/04/07, Paul.Divine@alcatel-lucent.fr
>>> <Paul.Divine@alcatel-lucent.fr> wrote:
>>>> Hi,
>>>> Just for test I put
>>>> org.apache.forrest.plugin.output.inputModule in the list of
>>>> plugin in the forrest.properties file.
>>>>
>>>> Note I use the java version j2sdk1.4.2_03.
>>>>
>>>> When trying to reach the index.html, the browser  displays the following
>>>> message
>>>>
>>>>
>>>> HTTP ERROR: 500
>>>> org%2Fapache%2Fforrest%2Fgeneration%2FModuleGenerator+%28Unsupported+major%2Eminor+version+49%2E0%29
>>>>
>>>> RequestURI=/index.html
>>> We are fully test on JDK1.4 and it should work, so this is probably a
>>> configuration problem on your end. Please provide the following info:
>>>
>>> Operating System
>>> Output of "java -version" command
>>> Output of JAVA_HOME
>> I think this is a problem with the plugin.  If you look at the
>> 0.8/org.apache.forrest.plugin.output.inputModule.zip there's a file
>> lib/org.apache.forrest.plugin.output.inputModule.jar.  It contains the
>> ModuleGenerator class.  This class has version 49.0, which is Java 5.
>>
>> My pod-input plugins seems to have the same problem.
>>
>> After a quick look into plugins/build.xml I think the javac task call
>> should contain target="1.4" to tell the compiler to always generate Java
>> 1.4 code.  Otherwise the compiler targets the default version, which is
>> the own version for recent Sun JDKs.
>>
> 
> Hmm, I think I used 1.5 to compile the inputModule plugin and Ron is
> right. Ron can you, please, attach a patch to our issue tracker for the
> build.xml? TIA.

Will do.

BTW, the inputModule manifest says:

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.6.5
Created-By: 1.5.0_07-b03 (Sun Microsystems Inc.)

Name: org/apache/forrest/
Comment: Support classes for Apache Forrest
Implementation-Title: org.apache.forrest
Implementation-Version: 0.8 April 14 2007
Implementation-Vendor: The Apache Software Foundation
Implementation-URL: http://forrest.apache.org/

> I can compile the plugin with 1.4 and this problems will go away, but
> not for 0.8, or?

I guess it should work when replaced at
http://forrest.apache.org/plugins/0.8/ .  If not, it may be necessary to
remove the plugin from %FORREST_HOME%\build\plugins first.

Ron

Mime
View raw message